Acknowledgements

The Industrial Design Section and the Footwear Section of the Institute of Biomechanics of Valencia (IBV) (www.ibv.org) developed this CD.

IBV is a technology center that promotes and carries out scientific research, technological development, technical consultancy, and training in biomechanics.

The IBV Footwear Section provides technical consultancy services to improve the functionality and comfort of footwear. The IBV Industrial Design Section provides industrial design and product development services including design consultancy, product specifications, design evaluation and verification, and prototyping.

The Footwear Section and the Industrial Design Section work together to incorporate tools that will improve product development workflow. This CD brings these tools to traditional footwear professionals.

We would like to thank The Art Company (www.the-art-company.com) for their collaboration and for allowing us to use their Traveler shoe to develop tutorials for the shoes in this CD.

We would like to thank the staff of the Pepe Herrero Group (www.pepeherrero.com) for their collaboration in reviewing the chapters related to the last.

Links

Hardware

MicroScribe Immersion Digitizing arm (www.immersion.com)
CNC ISEL milling machines (www.isel.com)

Authors and collaborators

Institute of Biomechanics of Valencia (www.ibv.org)
The Art Company (www.the-art-company.com)
Pepe Herrero Group (www.pepeherrero.com)

Plug-ins

ARL Expander (www.albacoreresearch.com)
Solecreator (www.rhino3d-design.com)
3DSole (www.3dsole.net)

Case study

Montrail: Hot New Boot Fit System Wows Hikers (www.rhino3d.com/users/montrail.htm)

Further study

Studio-Quality Rendering by Gijs de Zwart (www.flamingo3d.com/at.htm)
Table of Contents

1 Introduction to Shoe Design with Rhinoceros .................................................. 1
   About the Tutorials ...................................................................................... 1
   Developing a Design Concept ..................................................................... 1
   Rendering for Presentation ........................................................................ 2
   Prototyping and Manufacturing .................................................................... 2
   Following the Design Process ..................................................................... 3
   Pattern Making .......................................................................................... 5
   Footwear terminology .................................................................................. 5
      Parts of a shoe ...................................................................................... 5
      Shoe components .................................................................................. 5
      Parts of a last ...................................................................................... 6

2 Creating a Last Model .................................................................................. 8
   Creating a Last from Images of a Shoe ...................................................... 8
      Placing and calibrating the sketch images ........................................... 8
   Creating the three-dimensional sole curve .............................................. 11
   Creating the sole surface ........................................................................... 13
   Refining the sole curves .......................................................................... 14
   Creating the upper surface of the last ................................................... 15
   Improving the surface input ..................................................................... 17
   Creating a Last from Digitized Points ...................................................... 19
      Creating curves from the digitized points .......................................... 19
   Creating a preliminary upper surface .................................................... 25
   Creating a preliminary sole surface ....................................................... 25
   Improving the upper surface .................................................................... 27
   Improving the sole surface ....................................................................... 30
   Creating a Last from a Scanned Mesh Model .......................................... 33
      Creating section curves ...................................................................... 33
   Improving the sole edge curve ................................................................ 35
   Creating the upper surface ....................................................................... 36
   Creating the sole surface ......................................................................... 38

3 Modifying a Last Model ............................................................................. 39
   Raising the Heel ....................................................................................... 39
      Trimming the transition area from the last ....................................... 39
   Rotating the backpart .............................................................................. 42
   Trimming the surfaces .............................................................................. 43
   Creating a transition surface between the parts .................................... 43
   Setting the Toe Flare ............................................................................... 48
      Trimming the transition area from the last ....................................... 49
   Rotating the toe inward .......................................................................... 50
   Trimming the surfaces .............................................................................. 52
   Creating a transition surface between the parts .................................... 52
   Modifying Lasts Using Control Point Transformations .......................... 57
      Flaring the toe ...................................................................................... 57
   Setting the toe spring height with the Flow command .......................... 59
   Narrowing the toe .................................................................................... 61
4 Creating Outsoles and Insoles ......................................................... 64
  Creating a Simple Sandal Sole ..................................................... 64
  Creating a Boot Sole .................................................................... 71
    Alternate boot sole design ....................................................... 82
  Creating a Sole for a High-Heeled Shoe ....................................... 84
  Creating a Treaded Sole with Logo ............................................ 96
    Setting up the model .............................................................. 96
    Creating the basic sole volume ............................................. 97
    Creating the slipsole ............................................................ 103
    Creating the outsole ............................................................. 104
  Create an Insole ......................................................................... 112
    Setting up the model ............................................................ 112
    Scaling the sole .................................................................... 113
    Creating the insole thickness ............................................. 115
    Creating the heel pad and arch support ......................... 117
    Closing the insole ............................................................... 125

5 Modeling the Finish Details ........................................................ 131
  Finishing the Sandal ................................................................. 132
    Trimming the last to sandal shapes ..................................... 132
    Simulating the leather thickness ....................................... 134
  Finishing the Boot .................................................................... 136
    Trimming the last to boot shapes ...................................... 136
    Simulating the leather thickness ....................................... 138
    Modeling the boot lining .................................................... 139
    Modeling the decorative stitching .................................... 142
  Finishing the High-Heeled Shoe ................................................ 145
    Trimming last to vamp shape ............................................. 146
    Simulating the leather thickness and decorative piping .... 147
  Finishing the Teen Fashion Shoe ............................................. 149
    Trimming last to shoe shapes ............................................. 150
    Simulating the leather thickness ....................................... 152
    Creating the padded cuff .................................................... 153
    Modeling the lining ......................................................... 156
    Modeling the welt and stitching ....................................... 160
    Creating the eyelet tabs ..................................................... 163
    Creating the eyelets .......................................................... 165
    Creating the laces ............................................................... 168

6 Create Images ............................................................................ 172
  Types of Images ................................................................. 172
    Viewport captures ............................................................. 172
    Simple rendering with Treefrog ........................................ 173
    Raytrace render with Rhino render .................................. 174
    Sketch rendering with Penguin ........................................ 174
    Photorealistic rendering with Flamingo ......................... 175
  Set Up the Scene ................................................................. 176
    Make a pair and place the shoes ...................................... 176
    Set up the view ................................................................. 177
  Lighting ................................................................. 178
    High-heeled shoe ............................................................ 178
Teen shoe........................................................................................................................................180
Materials .........................................................................................................................................183
  High-heeled shoe....................................................................................................................183
  Teen shoe..................................................................................................................................186
Rendering Environment ..............................................................................................................188
Ground Plane ..............................................................................................................................189
1 Introduction to Shoe Design with Rhinoceros

Although there are software packages dedicated to 3-D shoe design, the modeling and rendering tools in Rhinoceros (Rhino) can be used in shoe design and development phases, particularly in designing and visualizing new shoe concepts and manufacturing components such as soles and insoles.

About the Tutorials

These are advanced tutorials. You should already have a working knowledge of Rhino V3.0 or later.

The tutorials use practical examples that cover using Rhino to work through designing a shoe from original concept, through visualization, to component manufacture. Topics include:

- Creating a last from images, digitizing, and scanning
- Modifying a last model using curve and surface editing
- Creating soles and insoles
- Modeling a complete shoe
- Creating images of the finished shoe models

Developing a Design Concept

Rhino can be used in the concept development stage as a natural step for moving from 2-D design tools such as Freehand and Adobe Illustrator, to a 3-D model.

Sketch with last model.

Finished 3-D shoe model.
Rendering for Presentation
Rhino’s own presentation tools and plug-in rendering packages such as Flamingo and Penguin can be used to validate new designs and to show new concepts to customers or other departments within the company.

Prototyping and Manufacturing
Shoe component models generated using Rhino can be used directly to manufacture prototypes and molds.

Rapid prototype of sole created with Object Eden 260.
Prototype mold for a sole for casting being cut with a CNC milling machine from ISEL Automation.

Following the Design Process

The workflow for the shoe design in these tutorials starts with modeling the last.

The last model is the basic shape of the foot that acts as a form around which the shoe is designed. The last can be approximated by tracing flat images or by digitizing or scanning existing lasts.

Digitizing a last with a MicroScribe digitizing arm.
Next, two-dimensional curves based on the last and style sketches are used to generate the insole, sole, and upper surfaces.

Sketch of upper from style sketch and last.

Finally, rendering materials are assigned to each component and a virtual scene with lighting and background is created. From this scene, images of the shoe model with a high level of realism can be generated.

Photo-realistic image of a shoe modeled in Rhino and rendered with Flamingo.
**Pattern Making**

Pattern making consists of flattening the 3-D surfaces that comprise the upper to create a template or pattern for cutting the leather or other material.  

While Rhino provides tools for conceptualizing designs and manufacturing certain components, features specifically for pattern making are not included.  

Currently, solutions are provided by Rhino plug-in applications such as ARL Expander, which can flatten these surfaces ([www.albacoreresearch.com/expander.html](http://www.albacoreresearch.com/expander.html)).

![Shoe model flattened using Rhino plug-in ARL Expander.](image)

**Footwear terminology**

Some terms used in the footwear industry are described below.

**Parts of a shoe**

Parts of a shoe: lining (1), tongue (2), vamp (3), welt (4), outsole (5), quarter (6), heel (7), backstay (8), topline (9). Source: Footwear Industries of America, Inc.

**Shoe components**

The terms vary among manufacturers of complete shoes and manufacturers of shoe components.  

The components of the complete shoe are shown:
Shoe components: tongue (1), vamp (2), heel stiffener (3), insole (4), midsole (5), shank (6), outsole (7), heel (8), top piece (9).

Parts of a last
A last is a piece of wood, metal, synthetic material, or an electronic model roughly duplicating the anatomy of the foot. In the manufacturing process, a physical last acts as a form on which the shoe is made.

The main elements of the last are shown.

Parts of a last: topline (1), heel (2), heel elevation (3), inside lateral surface (4), break zone (5), sole (6), last axis (7), toe (8), sole curve (9), outside lateral surface (10).
Last curves: heel curve (1), heel point (2), heel elevation (3), base plane (4), backpart (5), shank curve (6), forepart (7), tread point (8), last ball break (9), toe spring (10), vamp length (11), vamp point (12), instep point (13), v-cut (14). Source: Footwear Industries of America, Inc.
2 Creating a Last Model

This chapter describes the creation of lasts using three procedures: Tracing two-dimensional images, using a digitizing arm, and using data from a 3-D scanner.

Tracing two-dimensional images is a simple process for generating an approximated last using a side and a top view of a shoe. This approximated last can be useful in the early design stages.

Professionals in last manufacturing generally base new lasts on previously validated, successful designs. To do this, they generate 3-D models by digitizing existing lasts. Specialized scanners are used for this type of geometry; however, this tutorial describes generating lasts from digitized points with conventional digitizing arms or streaming laser scanners that provide a point cloud or a polygon mesh.

Creating a Last from Images of a Shoe

Using top view and side view sketches of a shoe as background images in the Rhino viewports, you can trace the appropriate curves in two dimensions and then create the three-dimensional model from these curves.

Placing and calibrating the sketch images

The images must be placed in a viewport and then calibrated to the shoe’s dimensions.

To place reference images in the viewports

1. Start a new Rhino model file using the millimeters template.
2. Create a *Curve* layer, and make it the current layer. (*Edit menu: Layers > Edit Layers*)
3. In the *Right* viewport, use the *Line* command to draw a *245 mm* reference line starting at *0,0,0*. (*Curve menu: Line > Single Line*)
4 In the **Right** viewport, use the **BackgroundBitmap** command, **Place** option to place the **shoeside.jpg** image. 

(View menu: Background Bitmap > Place)

Draw the placement rectangle without regard to its size. You will calibrate the bitmap’s size in the next step.

5 In the **Top** viewport, use the **BackgroundBitmap** command, **Place** option to place the **shoetop.jpg** image. 

(View menu: Background Bitmap > Place)

The next step is to calibrate the images to the shoe’s real size and origin point.

**To calibrate the side view image**

1 Start the **BackgroundBitmap** command, **Align** option. (View menu: Background Bitmap > Align)

2 At the **Base point on bitmap** prompt, on the image, pick the point of the upper in the heel area at the seam between the upper and the sole.

   A dot in the image marks the point.
3 At the **Reference point on bitmap** prompt, pick the point on the upper toe area at the seam.
   A dot in the image marks the point.

4 At the **Base point on CPlane** prompt, use the **End** object snap to select the left end of the reference line.

5 At the **Reference point on CPlane** prompt, use the **End** object snap to select the right end of the reference line.
The image in the **Right** viewport will now be the correct size.

6 **Repeat** these steps for the background bitmap in the **Top** viewport.

**Creating the three-dimensional sole curve**

Now that the shoe image is calibrated, you can trace elements of the image to create the last model. Start with the curve that defines the bottom of the last.

**To create the sole construction curves**

1. In the **Top** viewport, start the **InterpCrv** command. *(Curve menu: Free-form > Interpolate Points)*

2. Using the seam as a guide, draw a curve that follows the outline of the sole.
   
   A curve with 20 to 25 control points is usually enough. Edit the control points if the curve needs adjustment.
3 In the Right viewport, using the seam as a guide, use the InterpCrv command to draw a curve that defines the profile of the sole. (*Curve menu: Free-form > Interpolate Points*)

Draw the curve so that it extends a few millimeters beyond the sole curve at both ends.

4 Select the two curves and use the Crv2View command to create the 3-D sole curve. (*Curve menu: > Curve from 2 Views*)

5 In the Top viewport, using the Int object snap, use the Split command to divide the 3-D sole curve into two halves at the visual (apparent) intersections of the reference line with the sole profile curve. (*Edit menu: Split*)
Creating the sole surface

In the next step you will draw the last's central curve. This curve defines the curvature of the bottom of the last and the shank. You will then create a surface from the sole outline curve and the central curve.

To create the central curve

1. **Hide** all of the curves except the 3-D sole curve you just created. *(Edit menu: Visibility > Hide)*

2. In the **Right** viewport, using the image as a guide, use the **InterpCrv** command to draw a curve representing the center of the last. *(Curve menu: Free-form > Interpolate Points)*

   Start drawing at the heel of the sole curve. Use the **End** object snap to place the starting point at the end of the 3-D sole curve at the heel.

   Be sure to place one point in the lowest part of the last.

   Use the **End** object snap to place a point on the 3-D sole curve at the toe.
**Refining the sole curves**

To make surfaces that are simple, elegant, and compatible with each other, it is a good idea to refine the input curves so that their internal structure is compatible. For this model, we will refine the curves we have created using Rhino’s Rebuild command. The goal is to create curves with just enough control points to define the shape. For this model, 25 control points seems to work well.

**To rebuild the sole curves**

1. **Select** all three of the three sole curves, the split sole profile, and the central 3-D curve.
2. **Start** the Rebuild command. (*Edit menu: Rebuild*)
3. **In the Rebuild Curve** dialog box, set the **Point count** to 25 and the **Degree** to 3.
   
   - You may want to retain the old curves and to place the new curves on a new layer.
   - Now all three curves have a similar point structure.

**To create the sole surface**

1. **Create a Sole surface** layer, and make it the current layer. (*Edit menu: Layers > Edit Layers*)
2. **Select** the three sole curves.
3. **Use** the Loft command to generate the sole surface. (*Surface menu: Loft*)
   
   - Use the Normal loft style.
   - There is no need to use the Simplify or Refit options because you have already done this work by rebuilding your input curves.

4. **Once you have created the sole surface, use the Join command** to re-join the two halves of the sole profile curve. (*Edit menu: Join*)
Creating the upper surface of the last

In the next step you will create the front (vamp) and back (heel) profile and the topline curves using the sketch as a guide.

To draw the vamp curve

1. Set the **Curve** layer as the current layer. *(Edit menu: Layers > Edit Layers)*

2. In the **Right** viewport using the image as a guide, use the **InterpCrv** command to draw the front (or vamp) curve. *(Curve menu: Free-form > Interpolate Points)*
   - Use the **End** object snap, to start the curve at the toe end of the sole profile curve.
   - Use the **End** object snap to locate the end of the subcurve section.

3. Rebuild the vamp curve using **25** control points.

To draw and refine the topline curve

1. In the **Top** viewport, use the **InterpCrv** command to draw a closed curve to represent the topline. *(Curve menu: Free-form > Interpolate Points)*
   - Use the **End** object snap to start the curve at the end point of the vamp curve. Use **Planar** mode to keep the curve at the same elevation.
2 **Split** the topline curve at the apparent intersection of the topline curve and the reference line.

3 **Rebuild** the two halves of the topline curve using 25 control points.

4 **Join** the two halves of the topline curve.

**To draw and refine the heel curve**

1 In the **Right** viewport, use the **InterpCrv** command to draw the heel curve. (*Curve menu: Free-form > Interpolate Points*)

   Use the **End** object snap to start the curve at the end point of the sole curve and end the curve on the topline curve.

2 **Rebuild** the heel curve using 25 control points.

**To create the upper last surface**

1 Create a **Last surface** layer, and set it as the current layer. (*Edit menu: Layers > Edit Layers*)
2 Use the **Sweep2** command to create the surface. (*Surface menu: Sweep 2 Rails*)

Select the 3-D sole curve and the topline curve as the rails, and the vamp and heel curves as the cross-section curves.

3 In the **Sweep2** dialog box, select the **Closed sweep** check box.

---

**Improving the surface input**

The quality of the generated surface is not particularly good due to the limited geometry information. Therefore, we are going to create another surface with better information. To guide the surface over the central part of the upper more accurately, we will draw additional cross-section curves.

**To improve the last surface**

1 Create a **Last surface 2** layer, and set it as the current layer. (*Edit menu: Layers > Edit Layers*)

2 In the **Right** viewport, select the surface and use the **Section** command to draw section curves, drawing a vertical line near the ankle area. (*Curve menu: Curve From Objects > Section*)

Start the section line below the upper surface and end it above the upper surface. Use **Ortho** to guide the section line vertically.
3 In the Back viewpoint, edit the control points of the section curves to create the profile shape you like.

To create the new upper last surface

1 Set the Last surface layer as the current layer. (*Edit menu: Layers > Edit Layers*)

2 Use the **Sweep2** command to create the surface. (*Surface menu: Sweep 2 Rails*)
   Select the 3-D sole curve and the topline curve as the rails, and the vamp, heel, and the two new curves as the cross-section curves.

3 Use the **Join** command to join the side and upper surfaces you have created. (*Edit menu: Join*)

4 Use the **Cap** command to close the last solid at the topline. (*Solid menu: Cap Planar Holes*)

5 **Save** the file.

Greater detail can be added to the last by making more sections in other areas of the last, rebuilding them, editing them, and generating a new surface with the **Sweep2** command.
Creating a Last from Digitized Points

In this section, you are going to create a last model from digitized points. The points have been created using a MicroScribe digitizing arm following radial outlines drawn on the last.

Creating curves from the digitized points

The first step is to create curves that define the sole, topline, vamp, and heel curves.

To create the sole profile curve

1. Open the model Digitized last points.3dm.

   The lower edge of the last has been digitized with as much detail as possible along the last axis. This curve defines the shank and the curvature of the sole.

2. Create a Sole curves layer, and set it as the current layer. (Edit menu: Layers > Edit Layers)
3 Turn the **Sole profile scan points** layer on and turn the other layers off. *(Edit menu: Layers > Edit Layers)*

4 **Select** the sole profile points.

5 To create a curve through these points, use the **CurveThroughPt** command, with the **Closed** option set to **Yes**. *(Curve menu: Free-form > Fit to Points)*

---

**To create the last axis curve**

1 Turn the **Last axis points** layer on, and turn the other layers off. *(Edit menu: Layers > Edit Layers)*

2 **Select** the last axis points.
3 To create a curve through these points, use the CurveThroughPt command, with the Closed option set to No. (Curve menu: Free-form > Fit to Points)

4 Hide the last axis curve. (Edit menu: Visibility > Hide)

To create the topline curve

1 Create a Topline curve layer, and set it as the current layer. (Edit menu: Layers > Edit Layers)

2 In the Right viewport, select the scanned points at the top of the upper.

3 To create a curve through these points, use the CurveThroughPt command, with the Closed option set to Yes. (Curve menu: Free-form > Fit to Points)

4 Show the topline curve's control points, and adjust the points in each of the viewports until you are satisfied with the curve shape. (Edit menu: Visibility > Show)
To smooth the sole profile curve and topline curves

1. **Select** the sole and topline curves.
2. Start the **Rebuild** command. *(Edit menu: Rebuild)*
3. In the **Rebuild Curve** dialog box, set the **Point count** to 30 and the **Degree** to 3.
   
   The curves smooths without losing much detail.
   
   To eliminate other imperfections, manually adjust the curves’ control points.

To create the radial curves

1. Create a **Last curve** layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*
2. **Select** the points that correspond to the radial curve defining the front curve of the last (vamp).
   
   Try the **Lasso** command or use a window selection. *(Edit menu: Control Points > Select Control Points > Lasso)*

3. Use the **Invert** command to reverse the selection and the **Hide** command to hide all of the points except the vamp points. *(Edit menu: Select Objects > Invert and Edit menu: Visibility > Hide)*
4 To create a curve through these points, use the **CurveThroughPnt** command, with the **Closed** option set to **No**. (*Curve menu: Free-form > Fit to Points*)

5 **Rebuild** the curve with fewer control points (5 to 8 points can be enough). (*Edit menu: Rebuild*)

6 Use the **PointsOn** command to display the curve’s control points, and adjust the points in each of the viewports until you are satisfied with the curve shape. (*Edit menu: Control Points > Show control points*)

   You can use the **CurvatureGraph** command to refine the curvature. (*Analyze menu: Curvature Graph On*)

   It is a good idea to make the endpoints of the vamp curve lie exactly on the topline and sole profile cross-section curves.
7 Use the **PointsOn** command to display the control points on the vamp curve. *(Edit menu: Control Points > Show control points)*

8 Use the **Move** command with the **Point** and **Near** object snaps to move the control point at each end of the curve onto the cross-section curves. *(Transform menu: Move)*

9 **Repeat** these steps to generate the remaining radial curves.
Creating a preliminary upper surface

Create a preliminary upper surface from the curves. It is normal for this first surface to need refinement. You will add input curves to improve this surface in a later step.

To create the preliminary upper surface

1. Create a Last surface layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

2. Select all of the curves, and use the NetworkSrf command to create the upper last surface. *(Surface menu: Curve Network)*

3. Turn the last curves layer off. *(Edit menu: Layers > Edit Layers)*

4. To review the quality of the generated surface, use the EMap command. *(Analysis menu: Surface > Environment Map)*

5. Rotate the Perspective viewport to examine the quality of the surface. In this case, the surface does not have exactly the shape we want.

   We will improve this surface after we create the sole surface.

Creating a preliminary sole surface

You will now create a sole surface that we expect to refine.

To generate create the input curves for the sole surface

1. Turn the Sole curves layer on. *(Edit menu: Layers > Edit Layers)*

2. Copy with the InPlace option the central sole curve that corresponds to the last axis. *(Edit menu: Copy)*

3. Duplicate the lower edge of the last surface. *(Curve menu: Curve from Objects > Duplicate Edge)*
4 Use the **PointsOn** command to display the control points of the sole edge curve. *(Edit menu: Control Points > Control Points On)*

5 **Move** the central sole curve’s end control points so that they lie exactly on the duplicated sole edge curve. *(Transform menu: Move)*

6 **Split** the edge curve using the central curve as the cutting object. *(Edit menu: Split)*

---

To create the sole surface

1 Select the split edge curves and the central curve, and use the **Loft** command to generate the sole surface. *(Surface menu: Loft)*

2 Use the **Join** command to stitch the upper and sole together. *(Edit menu: Join)*
Improving the upper surface

The upper and sole surfaces are not as smooth and well defined as we would like them to be. Improving the surfaces requires additional cross-section curves to better control the surface creation.

To create additional input curves for the upper

1  In the **Right** viewport, on the construction plane, create two curves as shown. (*Curve menu: Free-Form > Control Points*)

2  Use the **Project** command to project these two curves onto the upper surface. (*Curve menu: Curve From Objects > Project*)

3  In the **Top** viewport, use the **Hide** command to remove the last surface from the view. (*Edit menu: Visibility > Hide*)

   We will now be able to see imperfections in the section curves.

To improve the quality of the cross-section curves

1  **Rebuild** the curves with 30 control points and degree 3. (*Edit menu: Rebuild*)

   Once the curve has been rebuilt, there still may be imperfections that we cannot see clearly.
2 To eliminate imperfections, use the PointsOn command to display the curve’s control points, and use the CurvatureGraphOn command to display the curvature graph. (Analyze menu: Curve > Curvature Graph On)

3 In the Curvature Graph dialog box, set the Display scale to 116.
4 Adjust the control points using the curvature graph as a guide, until the unwanted inflection points are eliminated as shown.

5 The final result should look similar to the image.

6 Close the Curvature Graph dialog box.

7 Use the NetworkSrf command to generate a new surface including the two new cross-section curves. (Surface menu: Curve Network)

   We can see how the surface has improved substantially compared with the previous one.
You can make similar adjustments to the vertical cross-section curves to refine the shape of the last.

Improving the sole surface
To improve the sole surface, we will add additional cross-section curves to guide the surface.

To create new cross-section curves

1. Copy the central sole curve that corresponds to the last axis. *(Edit menu: Copy)*

2. Duplicate the lower edge of the last surface you just created. *(Curve menu: Curve from Objects > Duplicate Edge)*

3. Use the PointsOn command to display the control points of the sole central curve. *(Edit menu: Control Points > Control Points On)*

4. Move the central sole curve’s end control points so that they lie exactly on the duplicated sole edge curve. *(Transform menu: Move)*

5. Split the edge curve using the central curve as the cutting object. *(Edit menu: Split)*
6 Use the \texttt{InterpCrv} command with the \texttt{Near} object snap to create some cross section curves across the sole. (\textit{Curve menu: Free-Form > Interpolate Points})

Start each curve on of the sole edge curves.
Place a point on the sole central curve.
Place the final point on the other sole edge curve.

To generate the sole surface

1 Select the new cross-section curves and the sole edge curves.

2 Use the \texttt{NetworkSrf} command to create the sole surface. (\textit{Surface menu: Curve Network})

This surface has more detailed control over the shape of the sole since you have provided more curves as input.
To close the last

1. In the Right viewport, draw a Polyline as shown in the image. *(Curve menu: Polyline > Polyline)*

2. Use the Extrude command to generate a surface that extends across the top of the last. *(Surface menu: Extrude Curve > Straight)*
   Make sure that it completely cuts the upper last surface at the topline.

3. Trim the upper last surface with the extruded surface and the extruded surface with the last surface. *(Edit menu: Trim)*

4. Join the upper, sole, and topline surfaces to make a closed polysurface. *(Edit menu: Join)*
Creating a Last from a Scanned Mesh Model

The process for creating a last from a mesh generated with a scanner is slightly different from using digitized points. You will create sections by projecting curves onto the mesh model and then use those section curves to model the last.

Creating section curves
The Section command will create your initial curves from the mesh.

To create section curves

1. Open the file Scanned last.dxf. The file contains a mesh of a last generated by stream digitizing with a scanner.

2. Use the Section command to generate enough curves (8–10) to define the shape of the last. (*Curve menu: Curve From Objects > Section*)
   - Create the curves that correspond to the upper surface with radial section curves.
   - Create the curves that define the sole surface with section curves perpendicular to the last’s longitudinal axis.

To refine the section curves

1. Hide the mesh. (*Edit menu: Visibility > Hide*)

2. Use the Split command to split each curve with the Point option at the theoretical intersection between the sole and upper surface of the last. (*Edit menu: Split*)
3 **Delete** any curves that seem redundant and keep the curves that provide the best basic surface information.

4 **Rebuild** the curves using the following point counts *(Edit menu: Rebuild)*:

<table>
<thead>
<tr>
<th>Last Part</th>
<th>Number of Control Points</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upper rear sections</td>
<td>5</td>
</tr>
<tr>
<td>Front radials</td>
<td>15</td>
</tr>
<tr>
<td>(Information from the toe can be lost, but the curves can be adjusted later.)</td>
<td></td>
</tr>
<tr>
<td>Sole cross sections</td>
<td>3</td>
</tr>
<tr>
<td>Central axis</td>
<td>10</td>
</tr>
</tbody>
</table>

5 Using the **InterpCrv** command with the **End** object snap, snap to the curve ends at the top and bottom of the section curves to create the topline and sole edge curves. *(Curve menu: Free-Form > Interpolate Points)*
**Improving the sole edge curve**

Due to imprecise splitting, the sole edge curve must be edited to improve its quality.

**To improve the sole edge curve**

1. Set the viewport display mode to **GhostedViewport**, and turn object snaps off. *(Right-click viewport title > Ghosted Display)*

2. Use the **InsertKnot** command to add more control points to the curve around the square toe. *(Edit menu: Control Points > Insert Knot)*

   It may also be useful to work with **Curvature Graph On**, to obtain smoother curves. *(Analyze menu: Curve > Curvature Graph On)*
Creating the upper surface

As in the previous example, we will create a preliminary surface and use that surface to create additional curves that will add detail to guide the final surface.

Create the preliminary surface

1. **Move** the control point at the end of each radial curve to coincide with the topline and sole edge curves. *(Transform menu: Move)*

2. Use the **NetworkSrf** command to create the upper surface using the topline and sole curves in one direction and the radial sections in the other. *(Surface menu: Curve Network)*

To improve the quality of the surface, add more curves to act as guides.
Improve the upper surface

1 In the **Front** viewport, use the **InterpCrv** command to create two curves as shown. *(Curve menu: Free-Form > Interpolate Points)*

2 **Select** the surface and the two curves and use the **Project** command to "wrap" the curves around the surface. *(Curve menu: Curve From Objects > Project)*

3 **Rebuild** the new curves with 10 to 20 control points and move the control points to edit them. *(Edit menu: Rebuild)*

4 Using the new curves, use the **NetworkSrf** command to create a new surface. *(Surface menu: Curve Network)*
Creating the sole surface
Use the same method to create the sole surface as in the previous example.

Create the sole surface

1. Use the **DupEdge** command to duplicate the lower edge of the last surface. *(Curve menu: Curve From Objects > Duplicate Edge)*
2. **Move** the control points at the ends of the last axis curve and the sole cross-section curves to coincide with the sole edge curve. *(Transform menu: Move)*
3. **Split** the sole edge curve using the last axis curve. *(Edit menu: Split)*
4. Use the **NetworkSrf** command to generate the sole surface. *(Surface menu: Curve Network)*
5. **Join** the sole and upper surfaces. *(Edit menu: Join)*
3 Modifying a Last Model

As we have seen in previous chapters, last manufacturers and footwear designers make use of existing lasts to develop a new last. They make modifications or blends between them to adjust the last to new footwear models or to offer new aesthetic lines.

Modifying a last is a three-step process:
1. Split the last into two basic areas: a fixed part and a part to be transformed.
2. Make the modification on the area to be transformed.
3. Create a surface that blends between the two areas.

A similar procedure can be used to join a body from one last and the toe from a different last.
1. Select a part to keep and a part to eliminate from each last.
2. Create a surface blend between the two parts.

When the modified last is made up of several surfaces, it is worthwhile to rebuild the last following the procedures from the previous chapter to make a new last that consists of only three surfaces.

We are now going to look at two typical modifications:
- Raising the heel
- Rotating the toe inward

The techniques described can also be used when blending two lasts.

Rhino deformation tools can also be used for aesthetic modifications.

Raising the Heel

To set the heel height, you will:

- Mark the last at the splitting point.
- Trim away a portion of the last between the forepart and the backpart to make room for the rotation.
- Rotate the backpart to establish the elevation.
- Create a transition surface between the two parts.

Trimming the transition area from the last

The first step is to mark points on the last. You need a reference line that defines the center of the transition between the forepart (toe section) and the backpart (heel section).
To set up the model

1. Open the file **Basic last.3dm**.
2. **SaveAs** a new file.

3. Create a **Modified last** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*
4. **Copy** the last with the **InPlace** option, and change the new polysurface to the **Modified last** layer. *(Transform menu: Copy and Edit menu: Layers > Change Object Layer)*
   - Or -
   Use the **Bonus Tools CopyToLayer** command to copy the last. *(Bonus menu: Edit > Copy to Objects to Layer)*
5. Turn the **Initial last** layer off. *(Edit menu: Layers > Edit Layers)*
6. Create a **Transition markers** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

To define the new heel height

1. In the **Right** viewport, use the **Line** command to draw a horizontal line from the far rear point of the edge defining the sole curve. *(Curve menu: Line > Single Line)*
2. **Copy** or **Offset** this line **20 mm** vertically as shown. *(Transform menu: Copy or Curve menu: Offset Curve)*
To define the transition area

1. Draw a Line that defines the center of the transition area that will be removed. *(Curve menu: Line > Single Line)*

   Use an average inclination between the line perpendicular to the vamp curve and the line perpendicular to the sole curve.

2. Offset this line 20 mm on either side of this line as shown. *(Curve menu: Offset Curve)*

To define the rotation point

Draw a reference line from the intersection of the inside sole edge and the central transition line.

1. Use the DupEdge command to create a curve from the edge of the sole surface. *(Curve menu: Curve From Objects > Duplicate Edge)*

2. In the Right viewport, use the Line command with the Int object snap to start the reference line at the apparent intersection of the edge curve and the central transition line. *(Curve menu: Line > Single Line)*

   Draw the line anywhere in space. You are only interested in the intersection point.
Rotating the backpart
To raise the heel area, you will rotate the backpart of the last around the intersection of the central line and the interior sole curve.

To split the shoe surfaces
1. **Explode** the last polysurface. *(Edit menu: Explode)*
2. In the **Right** viewport, **Split** the shoe surfaces at the central transition line. *(Edit menu: Split)*

To rotate the backpart
1. **Select** all the rear last surfaces (topline surface, upper, and sole).
2. In the **Right** viewport, use the **Rotate** command to rotate the parts. *(Transform menu: Rotate)*

   The base point of the rotation is the intersection of the central transition curve and the interior sole curve.

   Snap to the endpoints of the two horizontal lines that represent the current heel height and the new 20 mm height to establish the rotation angle.
Trimming the surfaces
Trim away the portions of the last surfaces between the lines that define the transition area.

To trim the surfaces
- In the Right viewport, use the Trim command to cut away the portions of the surfaces between the cut boundaries as shown. (Edit menu: Trim)

Creating a transition surface between the parts
There are two options for creating the transition surfaces:
- Use the BlendSrf command.
- Use the NetworkSrf command with additional curves perpendicular to the cutting edges.

To use a blend surface to join the parts
1. Create a new layer, and set it as the current layer. (Edit menu: Layers > Edit Layers)
2. Start the BlendSrf command. (Surface menu: Blend Surface)
3. Select the edges of the last surfaces as edges for the transition surface
4. In the Adjust Blend Bulge window, adjust the bulge amount so that the guiding curves give you the shape you want between the two surfaces.
5. Add more guide curves to if needed.
6. In the Adjust Blend Bulge dialog box, click OK.
The resulting transition surface will look like the image.

The transition surface is perpendicular to the original surface cutting edges and, therefore, may not follow the sole curve closely.

The following method for creating the surface is more difficult but allows better control over the shape of the join between the sole and the upper.

To use a create guiding curves for the surface

1. Create a new layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*

2. Start the **Blend** command. *(Curve menu: Blend Curves)*

3. At the **Select first curve to blend** ... prompt, set the **Continuity** option to **Curvature**, and select the lower edge curve of the back part of the upper surface.

4. At the **Select second curve to blend** ... prompt, select the lower edge curve of the toe part of the upper surface.

5. **Repeat** the procedure on the other side of the upper.
To create more blend curves

1. Start the **Blend** command again. *(Curve menu: Blend Curves)*

2. At the **Select first curve to blend ...** prompt, click **Perpendicular**.

3. At the **Select first curve to blend perpendicular from ...** prompt, select the edge curve of the upper.

4. At the **Point on curve for start of blend** prompt, pick a point on the edge curve.

5. At the **Select second curve to blend ...** prompt, click **Perpendicular**.

6. At the **Select second curve to blend perpendicular from ...** prompt, select the other edge curve.

7. At the **Point on curve for end of blend** prompt, pick a point on the edge curve.
8 Repeat the **Blend** command with the **Perpendicular** option to create at least one more curve to guide the surface.

To create the transition surface

- Use the **NetworkSrf** command with the **NoAutoSort** option to create a surface using the blend curves and the surface edges. *(Surface menu: Curve Network)*
  
  Select the sole edge blend curves and the added curves for the first direction.
  
  Select the naked edges of the upper surfaces for the second direction.
  
  Set the **Edge matching** options at the surface edges to **Tangency**.

To create the sole transition surface

1 Use the **Blend** command with the **Perpendicular** option to generate an auxiliary curve between the edges of the sole surfaces. *(Curve menu: Blend Curves)*
2 Start the **NetworkSrf** command with the **NoAutoSort** option. *(Surface menu: Curve Network)*

Select the edges of the upper transition surface and the auxiliary curve in the first direction.
Select the naked edges of the sole surfaces in the second direction.

In the **NetworkSrf** dialog box set the **Edge matching** option for edges A and C to **Position**.
Set the **Edge matching** option for edges B and D to **Tangency**.
To join the last

- **Select** all the surfaces and **Join** them to create a solid last. *(Edit menu: Join)*

To check the new last against the original

- Turn the layers for the initial last and the completed last on to compare the original last to the new last. *(Edit menu: Layers > Edit Layers)*

Setting the Toe Flare

*Flare* describes the curve of the last. Most modern shoes use a *banana* last, which displays an *inflate* or rotation of the toe toward the inside. The same process used to raise the height of the heel can be used for rotating the toe inward.

To rotate the toe area, you will:
- Mark the last at the splitting point.
- Split the last.
- Rotate the toe inward.
- Trim away a portion of the last to make room for the rotation.
- Create a transition surface between the two parts.
Trimming the transition area from the last

The first step is to mark points on the last. You need a reference line that defines the center of the transition between the toe section that will be rotated and the rest of the last.

To set up the model

1. Open the file Basic last.3dm.
2. Save as a new file.
3. Create a Modified last layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*
4. Copy the last to the Modified last layer. *(Bonus menu: Edit > Copy Objects to Layer)*
5. Turn the Initial last layer off. *(Edit menu: Layers > Edit Layers)*
6. Create a Transition markers layer, and make it the current layer.

To split the last

1. Draw a Line that defines the center of the transition area. *(Curve menu: Line > Single Line)*
2 Explode the last. (Edit menu: Explode)

3 In the Top view, Split the last upper and sole surfaces with the central split line. (Edit menu: Split)

Rotating the toe inward

You will rotate the separated toe section of the last around a point on the central split line.

To rotate the toe

1 Select the toe upper and sole surfaces.

2 Start the Rotate command. (Transform menu: Rotate)

3 As the Center of rotation prompt, use the Near object snap to pick a point on the central line.

4 At the Angle ... prompt, enter -15.
To trim the surfaces

1. Use the **Rotate** command with the **Copy** option to rotate and copy the central line. *(Transform menu: Rotate)*

2. At the **Center of rotation** prompt, use the **End** object snap to pick the outside endpoint of the central line.

3. At the **Angle** … prompt, enter **-7.5**.

4. At the next **Angle** … prompt, enter **7.5**.

5. **Move** the rotated line nearest the heel **10 mm** toward the heel. *(Transform menu: Move)*

6. **Move** the front rotated line **20 mm** toward the toe.

   The goal is to move the lines far enough so the transition curves do not exhibit much curvature change.
Trimming the surfaces
Trim away the portions of the last surfaces between the lines that define the cut boundaries.

To trim the last

- Select the forward and rear lines, and use the Trim command to remove the parts of surfaces inside the transition area. *(Edit menu: Trim)*

Creating a transition surface between the parts
In this case, we will create section curves between the toe and rear portion of the last and use a surface network to create the transition surface using the section curves and the edge curves of the last surfaces.

To create a transition surface between the two parts

1. Create a new layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*
2. Start the Blend command. *(Curve menu: Blend Curves)*
3. At the Select first curve to blend ... prompt, set the Continuity option to Curvature and select the lower edge curve of the back part of the upper surface.
4. At the Select second curve to blend ... prompt, select the lower edge curve of the toe part of the upper surface.
5 Repeat the procedure on the other side of the upper.

6 Repeat the **Blend** command with the **Perpendicular** option to create three to six more curves to guide the surface.

To improve the transition surface, you can edit the curves’ control points. Avoid moving the two control points at each end to maintain tangency with the adjacent surfaces.
To edit the curve control points

- Adjust the curve control points until you are satisfied with the curve shape.

To create the transition surface

- Use the NetworkSrf command with the NoAutoSort option to create a surface using the blend curves and the surface edges. (Surface menu: Curve Network)
  
  Select the sole edge blend curve and the auxiliary section curves in the first direction.
  
  Select the naked edges of the upper surfaces in the second direction.
  
  Set the Edge matching options at the surface edges to Curvature.
To create the sole blend surface

1. Use the **Blend** command with the **Perpendicular** option to generate three auxiliary curves between the edges of the sole surfaces. (*Curve menu: Blend Curves*)

2. Start the **NetworkSrf** command with the **NoAutoSort** option. (*Surface menu: Curve Network*)

   Select the edges of the upper transition surface and the auxiliary section curves in the first direction.

   Select the naked edges of the sole surfaces in the second direction.

   In the **NetworkSrf** dialog box set the **Edge matching** option for edges A and C to **Position**.

   Set the **Edge matching** option for edges B and D to **Continuity**.
To join the last

- Select all the surfaces and Join them to create a solid last. *(Edit menu: Join)*

To check the new last against the original

- Turn the layers for the initial last and the completed last on to compare the original last to the new last. *(Edit menu: Layers > Edit Layers)*
Modifying Lasts Using Control Point Transformations

Another method for modifying a last model is to use Rhino’s Flow and Taper commands on the upper and sole surfaces. These commands eliminate the steps required to split the surfaces and to create the transition surfaces.

Flaring the toe

You can use the Flow command to flare the toe inward. The Flow command allows the surface to follow a curve.

To set up the model

1. Open the file Basic last.3dm.
2. SaveAs a new file.
3. Explode the polysurface. *(Edit menu: Explode)*
4. Use the Group command to create a group from the resulting surfaces. *(Edit menu: Groups > Group)*
   
   In Rhino V3.0 or earlier, the Flow command can only be applied to surfaces and not to polysurfaces.
5. Create a Curves 1 layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*
To create the reference curves

1 In the Top viewport, use the Curve command to draw a curve that shows your desired toe flare. *(Curve menu: Free-Form > Control Points)*

   The curve should have the first two control points in line longitudinally and the curve should encompass the area that you want to modify, slightly overhanging the end of the last.

2 Use the Length command to determine the length of the curve you have just drawn. *(Analyze menu: Length)*

3 Use the Line command to draw a straight line with this length that shares the start point with the previous curve. *(Curve menu: Line > Single Line)*

4 Select the surface group and start the Flow command.

5 At the Original backbone curve ... prompt, select the straight line.

6 At the New backbone curve ... prompt, select the curve that defines the flare.

7 Join the last surfaces. *(Edit menu: Join)*
To check the new last against the original

- Turn the layers for the initial last and the completed last on to compare the original last to the new last. *(Edit menu: Layers > Edit Layers)*

Setting the toe spring height with the Flow command

The *toe spring* is the elevation of the undersurface of the sole at the toe that gives a slight rocker effect to the shoe.

To set up the model

1. Open the file **Basic last.3dm**.
2. **Save** as a new file.
3. Create a **Modified last** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*
4. **Copy** the last to the **Modified last** layer. *(Bonus menu: Edit > Copy Objects to Layer)*
5. Turn the **Initial last** layer off. *(Edit menu: Layers > Edit Layers)*
6. **Explode** the polysurface. *(Edit menu: Explode)*
7. Use the **Group** command to create a group from the resulting surfaces. *(Edit menu: Groups > Group)*
   - In Rhino V3.0 or earlier, the Flow command can only be applied to surfaces and not to polysurfaces.
8. Create a **Curves 2** layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*
To create the reference curves

1 In the **Right** viewport, use the **Curve** command to draw a curve that shows your desired toe spring. *(Curve menu: Free-Form > Control Points)*

2 Use the **Length** command to determine the length of the curve you just created. *(Analyze menu: Length)*

3 Use the **Line** command to draw a straight line with this length that shares the start point with the previous curve. *(Curve menu: Line > Single Line)*

4 **Select** the surface group and start the **Flow** command. *(Transform menu: Flow along Curve)*

5 At the **Original backbone curve ...** prompt, select the straight line.

6 At the **New backbone curve ...** prompt, select the curve that defines the flare.

7 **Join** the last surfaces. *(Edit menu: Join)*

**To check the new last against the original**

- Turn the layers for the initial last and the completed last on to compare the original last to the new last. *(Edit menu: Layers > Edit Layers)*
Narrowing the toe
The basic last has a fairly wide toe. In the next step, you will narrow the toe area.

To set up the model

1. Open the file Basic last.3dm.
2. Save as a new file.
3. Create a Modified last layer, and make it the current layer. (**Edit menu: Layers > Edit Layers**)
4. Copy the last to the Modified last layer. (**Bonus menu: Edit > Copy Objects to Layer**)
5. Turn the Initial last layer off. (**Edit menu: Layers > Edit Layers**)
6. Explode the polysurface. (**Edit menu: Explode**)
7. Use the Group command to create a group object from the resulting surfaces. (**Edit menu: Groups > Group**)
   
   In Rhino V3 or earlier, the Taper command can only be applied to surfaces and not polysurfaces.
8. Select the surface group and start the Taper command. (**Transform menu: Taper**)
9. In the Top viewport, locate the axis start in a central area of the last where you want to start narrowing the toe.
10. Locate the axis end point beyond the toe in line with the first point.
11 As the start distance, select a point outside the last and interactively adjust the new start distance according to the new toe design.

To check the new last against the original

- Turn the layers for the initial last and the completed last on to compare the original last to the new last. (*Edit menu: Layers > Edit Layers*)
4 Creating Outsoles and Insoles

In this chapter we are going to create outsoles using a 3-D last model and style sketches as references to generate the curves that define the structure.

We will look at four examples:
- a simple sandal sole in a single block.
- a men’s shoe sole.
- a women’s shoe with a high heel.
- a teen fashion shoe in detail, including cleats and logo.

Creating a Simple Sandal Sole

In this example, we will create a simple sandal sole consisting of a single block based on the last sole surface. The solid sole will be properly closed so it can be exported to any CAM program for manufacturing using injection or casting molds.

To set up the model

1. Open the file Sandal last.3dm.
2. Save as a new file.

3. In the Right viewport, use the BackgroundBitmap command Place option to place the sandal side.jpg sketch. (View menu: Background Bitmap > Place)
   Draw the placement rectangle over the last, making the placement rectangle slightly larger than the last.

4. Use the GhostedViewport command to set the viewport display. (Right-click viewport title > Ghosted Display)

To adjust the image and the last to each other

1. In the Right viewport, use the BackgroundBitmap command, Move option to move the toe of the background sketch to match the last. (View menu: Background Bitmap > Move)
Make the front point of the sole in the sketch coincide with the front point of the last model, matching the front point of the sole curve.

2 Use the Rotate command to rotate the last around the toe point so that the lowest point of the heel matches the image. (*Transform menu: Rotate*)

3 Use the BackgroundBitmap command, Scale option to set the size of the sketch to match the last. (*View menu: Background Bitmap > Scale*)

   Align the front of the sole curve with the toe of the last and the back of the sole with the heel as shown.

**To create a starting surface**

1 Create a Sandal sole layer, and make it the current layer. (*Edit menu: Layers > Edit Layers*)

2 Use the ExtractSrf command with the Copy option to create a copy of the sole surface. (*Solid menu: Extract Surface*)

3 Use the ChangeLayer command to change the layer of the extracted sole surface to the Sandal sole layer. (*Edit menu: Layers > Change Object Layer*)
4 Turn the **Sandal last** layer off. *(Edit menu: Layers > Edit Layers)*

**To define the bottom of the sole**

1 In the **Right** viewport, following the sketch, use the **InterpCrv** command to draw a curve that defines the lower edge of the sole in side view. *(Curve menu: Free-Form > Interpolate Points)*

2 Use the **Line** command to draw the front and rear outlines of the sole using the last sole surface edge. *(Curve menu: Line > Single Line)*

Make sure the curves overhang the curves of the sketch. This makes cutting the surfaces later easier.
3 Use the **DupEdge** command to copy the last sole surface edges and join them into a single curve. *(Curve menu: Curve From Objects > Duplicate Edge)*

To create the sole sides

1 Use the **Sweep1** command with the **Closed** option to generate the sole side surface. *(Surface menu: Sweep 1 Rail)*

   Use the sole outline curve as the rail and the front and rear outline curves as the cross-section curves.
To trim the sole bottom

1. Select the bottom sole curve, and use the ExtrudeCrv command with Mode set to Straight and the BothSides option to create a surface extending beyond the side surface on both sides. *(Surface menu: Extrude Curve > Straight)*

2. Select the side surface and the extruded bottom surface.

3. Start the Trim command. *(Edit menu: Trim)*
4 **Trim** the skirt overhanging the side surface of the sole with the sole bottom surface. *(Edit menu: Trim)*

5 **Trim** the extruded sole bottom surface with the side surface. *(Edit menu: Trim)*

6 **Join** the sole bottom, side, and original sole surface to generate a single closed polysurface. *(Edit menu: Join)*
7 Use the **FilletEdge** command with a radius of **2 mm** to create a rounded edge between the lower surface and the side. (*Solid menu: Fillet Edge*)

8 Use the **Properties** command and click **Details** to make sure the sole is a closed polysurface. (*Edit menu: Object Properties*)
Creating a Boot Sole

In this example, we are going to look at a basic boot sole.
Once again, we will base this development process on a last model and a style sketch.

To set up the model

1. Open the file Boot last.3dm.
2. Save as a new file.

3. In the Right viewport, use the BackgroundBitmap command, Place option to place the Boot side.jpg sketch. (View menu: Background Bitmap > Place)
   Draw the placement rectangle over the last, making the placement rectangle slightly larger than the last.

4. Use the GhostedViewport command to set the viewport display. (Right-click viewport title > Ghosted Display)

To adjust the sketch and the last to each other

1. In the Right viewport, use the BackgroundBitmap command, Move option to move the toe of the sketch to match the last. (View menu: Background Bitmap > Move)
   Make the front point of the sole in the sketch coincide with the front point of the last model, matching the front point of the sole curve.
2 Use the **Rotate** command to rotate the last around the toe point so that the lowest point of the heel matches the sketch. *(Transform menu: Rotate)*

3 Use the **BackgroundBitmap** command, **Scale** option to set the size of the sketch to match the last. *(View menu: Background Bitmap > Scale)*

   Align the front of the sole curve with the toe of the last and the back of the sole with the heel as shown.
**To create the internal surfaces defining the sole box**

1. Create an **Internal surface** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

2. Use the **OffsetSrf** command to offset the last polysurface **2 mm** to the outside. *(Surface menu: Offset Surface)*

   The offset value corresponds approximately to the thickness of the upper leather.

3. Turn the **Boot last** layer off. *(Edit menu: Layers > Edit Layers)*
To trim the sole internal surface

1. In the **Right** viewport, following the sketch, use the **InterpCrv** command to draw a curve that defines the upper edge of the sole. *(Curve menu: Free-Form > Interpolate Points)*

2. Use the **Trim** command with the curve as the cutting object to trim away the upper part of the side surface. *(Edit menu: Trim)*

We now would like to make a smooth blend surface between the sole side and the sole bottom. We cannot produce the surface we want with a rolling ball fillet as we did in the previous example because the distance between the surface edges varies. We will trim the two surfaces with a temporary surface and then create a blend surface between them.
To create defining curves

1. **Hide** the side surface. *(Edit menu: Visibility > Hide)*

2. Use the **DupBorder** command to extract a duplicate of the sole edge curve. *(Curve menu: Curve From Objects > Duplicate Border)*

3. Use the **Circle** command with the **AroundCurve** option to draw a circle with a **2.5 mm** radius around the duplicated edge curve at the toe. *(Curve menu: Circle > Center, Radius)*

4. Use the **Circle** command with the **AroundCurve** option to draw a circle with a **2.5 mm** radius around the duplicated edge curve at the end point of the heel. *(Curve menu: Circle > Center, Radius)*
To create a temporary trimming surface

1 Use the **Sweep1** command with the **Closed sweep** option using the sole edge curve as the rail and the two circles as the cross sections. *(Surface menu: Sweep 1 Rail)*

2 Use the tubular surface to **Trim** the areas of the side surface and the sole surface that are inside the tube.
   - **Tip:** Use **WireframeViewport** display and **Hide** the surface you are not trimming to make it easier to see.

3 **Delete** the tube.

To create the transition surface

1 Use the **BlendSrf** command to create the transition surface between the sole bottom and surfaces. *(Surface menu: Blend Surface)*
   - Add guide curves if necessary.
2 Join the three surfaces. *(Edit menu: Join)*

To create the external surface

1 Create an **External surfaces** layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*

2 Using the sketch as a guide, use the **InterpCrv** command to draw the two front and rear curves that define the side shape of the sole. *(Curve menu: Free-Form > Interpolate Points)*

   These curves must extend beyond the lower limit of the sole so they create a surface that can be trimmed with the curve that defines the bottom of the sole.

3 Use the **Sweep1** command to create the side surface of the sole. *(Surface menu: Sweep 1 Rail)*

   Use the interior surface edge curve as the rail and the two curves generated in front and behind as the cross-section curves.
If you wish to have more control over the geometry of the side sole surface, you can enter as many transversal curves as required.

**To trim the exterior surface**

1. In the **Right** viewport, use the **InterpCrv** command to draw the curve that defines the sole’s bottom surface. *(Curve menu: Free-Form > Interpolate Points)*

   The curve must overhang the sole surface at the front and at the back.
2 Use the **ExtrudeCrv** command with **Mode** set to **Straight** and the **BothSides** option to create a surface extending beyond the side surface on both sides. (*Surface menu: Extrude Curve > Straight*)

3 **Trim** the skirt overhanging the side surface of the sole with the sole surface. (*Edit menu: Trim*)
4 Trim the extruded sole surface with the side surface. *(Edit menu: Trim)*

To create a blend surface on the lower edge

1 Hide the side surface. *(Edit menu: Visibility > Hide)*

2 Use the DupBorder command to extract a duplicate of the sole edge curve. *(Curve menu: Curve From Objects > Duplicate Border)*

3 Use the Circle command with the AroundCurve option to draw circles around the lower sole edge with the radii that are appropriate to the rounding you want to carry out in each area. *(Curve menu: Circle > Center, Radius)*
4 Use the **Sweep1** command with the **Closed sweep** option using the sole edge curve as the rail and the circles as the cross sections. *(Surface menu: Sweep 1 Rail)*

5 Use the tubular surface to **Trim** the areas of the side surface and the bottom sole surface that are inside the tube. *(Edit menu: Trim)*

   **Tip:** Use **WireframeViewport** display and **Hide** the surface you are not trimming to make it easier to see.

6 **Delete** the tube.

---

**To create the transition surface**

1 Use the **BlendSrf** command to create the transition surface between the sole bottom and surfaces. *(Surface menu: Blend Surface)*

   Add guide curves if necessary.
2 Join the three surfaces. (Edit menu: Join)

Alternate boot sole design
You can easily alter the sole design by creating a different set of circles to guide the trimming surface.

To create an alternate design

1 Use the Circle command with the AroundCurve option to draw a more exaggerated set of circles around the lower sole edge. (Curve menu: Circle > Center, Radius)
2. Use the **Sweep1** command with the **Closed sweep** option using the sole edge curve as the rail and the circles as the cross sections. *(Surface menu: Sweep 1 Rail)*

3. Use the tubular surface to **Trim** the areas of the side surface and the sole surface that are inside the tube. *(Edit menu: Trim)*

4. **Delete** the tube.

5. Use the **Blendsrf** command to create the transition surface between the sole bottom and side surfaces. *(Surface menu: Blend Surface)*

   - Add extra guide curves and adjust the end bulge to control the shape of the blend.

*Simple sole shape.*  
*Alternate sole shape.*
Creating a Sole for a High-Heeled Shoe

In this example we are going to develop a sole with constant thickness for a high-heeled shoe with a fine heel. The requirement for a constant thickness is so that prefabricated leather can be used.

To set up the model

1. Open the file **High heel last.3dm**.
2. Save as a new file.
3. In the **Right** viewport, use the **BackgroundBitmap** command, **Place** option to place the **High heel side.jpg** sketch. (View menu: Background Bitmap > Place)

   Draw the placement rectangle over the last, making the placement rectangle slightly larger than the last.

4. Use the **GhostedViewport** command to set the viewport display. (Right-click viewport title > Ghosted Display)

To adjust the sketch and the last to each other

1. In the **Right** viewport, use the **BackgroundBitmap** command, **Move** option to move the toe of the sketch to match the last. (View menu: Background Bitmap > Move)

   Make the front point of the sole in the sketch coincide with the toe point of the last model, matching the toe point of the sole curve.

2. Use the **Rotate** command to rotate the last around the toe point so that the lowest point of the heel matches the sketch. (Transform menu: Rotate)
3. Use the `BackgroundBitmap` command, `Scale` option to set the size of the sketch to match the last. *(View menu: Background Bitmap > Scale)*

   Align the front of the sole curve with the toe of the last and the back of the sole with the heel as shown.

---

**To create a starting surface**

1. Create a `Sole` layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

2. Use the `ExtractSrf` command with the `Copy` option to create a copy of the sole surface. *(Solid menu: Extract Surface)*

3. Use the `ChangeLayer` command to change the layer of the sole surface to the `Sole` layer. *(Edit menu: Layers > Change Object Layer)*

4. Turn the `Surfaces` layer off. *(Edit menu: Layers > Edit Layers)*
To define the bottom of the sole

1. In the **Right** viewport, following the sketch, use the **InterpCrv** command to draw a curve that defines the bottom of the sole in side view. *(Curve menu: Free-Form > Interpolate Points)*

2. Use the **InterpCrv** command to draw the front and rear outlines of the sole snapping to the last sole surface edge. *(Curve menu: Free-Form > Interpolate Points)*

   Make sure the curves overhang the curves of the sketch. This makes cutting the surfaces later easier.
3 Use the **DupBorder** command to copy the last sole surface edges. *(Curve menu: Curve From Objects > Duplicate Border)*

---

**To create the sole sides**

- Use the **Sweep1** command to generate the sole side surface. *(Surface menu: Sweep 1 Rail)*
  
  Use the edge curve as the rail and the front and rear outline curves as the cross-section curves.
To trim the sole bottom

1 Use the **ExtrudeCrv** command with **Mode** set to **Straight** and the **BothSides** option to extrude the bottom sole curve into a surface extending beyond the side surface as shown. *(Surface menu: Extrude Curve > Straight)*

2 **Select** the side surface and the extruded bottom surface.

3 Start the **Trim** command. *(Edit menu: Trim)*
4 **Trim** the skirt overhanging the side surface of the sole with the bottom sole surface. 
*(Edit menu: Trim)*

5 **Trim** the extruded bottom sole surface with the side surface. 
*(Edit menu: Trim)*

6 **Use the DupBorder command to duplicate the edge of the top sole surface.** 
*(Curve menu: Curve From Objects > Duplicate Border)*
7 Use the **Pipe** command with a radius of **1.5 mm** to create a round surface around the duplicated sole edge. *(Solid menu: Pipe)*

8 Use the **Trim** command with the pipe surface as the cutting object to trim away the portions of the top sole surface and the side sole surface that are inside the pipe. *(Edit menu: Trim)*

9 Use the **BlendSrf** command to create a surface between the top sole surface and the side sole surface. *(Surface menu: Blend Surface)*

   Add as many bulge adjustment curves as are needed to guide the surface.

10 Use the **Join** command to join the top, side, and bottom sole surface and the blend surface. *(Edit menu: Join)*
11 Use the **Properties** command to make sure the sole is a closed polysurface. *(Edit menu: Object Properties)*

---

**To create the heel**

1. Create a **Heel** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

2. Use the **ExtractSrf** command with the **Copy** option to duplicate the lower sole surface. *(Solid menu: Extract Surface)*

3. Use the **ChangeLayer**, **Properties**, or **Layer** dialog box to change the surface to the **Heel** layer. *(Edit menu: Layers > Change Object Layer)*

4. Use the **ExtractIsocurve** command to create a curve from the lower sole surface that defines the limit of the flat area of the heel. *(Curve menu: Curve From Objects > Extract Isocurve)*
5 **Trim** the duplicated sole surface with the extracted isocurve. *(Edit menu: Trim)*

6 In the **Right** viewport, use the **InterpCrv** command to draw the front and rear curves defining the outline of the heel. *(Curve menu: Free-Form > Interpolate Points)*

   Use the heel curves obtained from the bottom sole surface as a reference.

7 In the **Top** viewport, use the **InterpCrv** command to draw the silhouette of the heel cap. *(Curve menu: Free-Form > Interpolate Points)*
8 Use the **DupBorder** command to duplicate the border of the trimmed sole surface. 
*(Curve menu: Curve From Objects > Duplicate Border)*

9 Use the **Sweep2** command to create the heel. *(Surface menu: Sweep 2 Rails)*

   - Use the front and rear curves as the rails.
Use the curves that define the cap and the heel as the cross-section curves.

In the Top viewport, align the curve direction and start points as shown.
10 Join the heel surface and the trimmed sole surface. (*Edit menu: Join*)

11 Use the **Cap** command to close the heel. (*Solid menu: Cap Planar Holes*)
Creating a Treaded Sole with Logo

In this example, we are going to recreate a teen fashion sole from The Art Company including the detail of the sole tread and the logo.

Setting up the model

This model uses two background sketches to create the sole curves from two views.

To set up the model

1. Start a new model.

2. Use the Line command to draw a **280 mm** straight line vertically in the Bottom viewport. *(Curve menu: Line > Single Line)*

   We will use the line to scale our background sketches.

3. In the Bottom viewport use the BackgroundBitmap command, Place, Move, Scale, or Align, options to place and orient the sketch Teen shoe sole.jpg as shown. *(View menu: Background Bitmap)*
Creating the basic sole volume

In this step, you will create the basic sole volume. The other parts of the sole will be based on this volume.

To draw the lower sole outline curve

1. In the **Bottom** viewport, use the **InterpCrv** command to draw a curve that defines the sole boundary. *(Curve menu: Free-Form > Interpolate Points)*
   
   Use 20 to 25 points. Edit the points and adjust if necessary.

2. In the **Right** viewport use the **BackgroundBitmap** command, **Place**, **Move**, **Scale**, or **Align**, options to place and orient the sketch **Teen shoe side.jpg**. *(View menu: Background Bitmap)*

3. Use the **InterpCrv** command to draw a curve that defines the sole’s lower edge. *(Curve menu: Free-Form > Interpolate Points)*
   
   This is the line between the sole and the tread.
4 **Select** the sole boundary curve and the sole lower edge curve.

5 Use the **Crv2View** command to create the 3-D curve that defines the sole edge. *(Curve menu: Curve From 2 Views)*

---

**To draw the upper sole curve**

1 In the **Right** view, use the **InterpCrv** command to draw the curve defining the upper part of the sole. *(Curve menu: Free-Form > Interpolate Points)*
2 use the InterpCrv command to draw the front and rear sole outlines. *(Curve menu: Free-Form > Interpolate Points)*

Make sure that the curves overhang the curves on the sketch. This will make it easier to trim the surfaces created from these curves later.

**To create the sole side surface**

1 Create a new layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

2 Use the **Sweep1** command to generate the sole side surface. *(Surface menu: Sweep 1 Rail)*

Use 3-D sole edge curve as the rail and the front and rear outlines as cross-section curves.
Select the **Closed sweep** option.
Use the **Rebuild with** option and **10** control points.

**To trim the sole side surface at the lower edge**

1. Use the **ExtrudeCrv** command with **Mode** set to **Straight** and the **BothSides** option to extrude the bottom sole curve into a surface extending beyond the side surface as shown. *(Surface menu: Extrude Curve > Straight)*
2 Select the side surface and the extruded bottom surface.

3 Start the Trim command. (Edit menu: Trim)

4 Trim the skirt overhanging below the side surface of the sole with the bottom sole surface.

To trim the sole side surface at the upper edge

1 Use the ExtrudeCrv command with Mode set to Straight and the BothSides option to extrude the top sole curve into a surface extending beyond the side surface as shown. (Surface menu: Extrude Curve > Straight)
2 Select the side surface and the extruded top surface.

3 Start the Trim command. (Edit menu: Trim).

4 Trim the skirt overhanging the upper side surface of the sole with the upper sole surface and the top surface to the side.
Creating the slipsole

You have just created the sole's basic volume, you will now split that volume to create a surface that represents the shoe's slipsole. A slipsole is a thin strip of material set between the insole and the outsole of a shoe, usually for height.

To create the surfaces for the slipsole:

1. Use the Copy command to make two copies of the top sole curve at positions that correspond to the sketch lines. (Transform menu: Copy)

2. Use the ExtrudeCrv command with Mode set to Straight and the BothSides option to extrude the copied slipsole section curves into surfaces extending beyond the side surface. (Surface menu: Extrude Curve > Straight)
   
   You can extrude both curves at the same time.

3. Use the Split command to split the side sole surface with the two slipsole section surfaces. (Edit menu: Split)

4. Delete the section cutting surfaces.

5. Use the ChangeLayer, Properties, or Layer dialog box to change the surfaces to a new Slipsole layer. (Edit menu: Layers > Change Object Layer)
Creating the outsole
The outsole of the teen shoe will include the cleats and raised logo lettering.

To create the outsole starting solid

- Use the ExtrudeSrf command Straight option to thicken the bottom surface of the sole, using the background sketch as a guide. (*Solid menu: Extrude > Surface*)

To create the logo text

1. On a new layer, in the Bottom viewport, start the TextObject command. (*Solid menu: Text*)

2. In the Text Object dialog box, in the Text to create box, type The Art Company.
   Under Font, in the Name box, select Impact.
   Under Create, select Curves and Group objects.
   Under Text size, set the Height to 25 millimeters.
3 Use the **Rotate** command to rotate the text 90 degrees, so it reads from the bottom of the screen to the top. (*Transform menu: Rotate*)

4 Use the **Scale1D** command to scale the text group vertically to match the sketch size. (*Transform menu: Scale > Scale 1-D*)

5 Use the **Move** command to position the text over the sketch. (*Transform menu: Move*)
6 **Rotate** the text until the T lines up with the sketch. *(Transform menu: Rotate)*

7 Use the **Bend** command to curve the text until the arc is similar to the arc of the text in the sketch. *(Transform menu: Bend)*

   Situate the start of the spine at a point below the letter T and the end of the spine above the Y.

   Make adjustments to the scale, bend, rotation, and position until the text matches the sketch as closely as you like.

---

**To create the tread curves**

1 On a new **Tread** layer, in the **Bottom** viewport, use the **Rectangle** command to draw a rectangle approximately **11** by **9** mm.

2 Use the **Copy**, **Move**, and **Rotate** commands or the **Orient** command to place copies of the rectangle over each cleat in the sketch. *(Transform menu: Move, Copy, Rotate or Transform menu: Orient > 2 Points)*
3 Use the **InterpCrv** command to draw the curves that define the text area. *(Curve menu: Free-Form > Interpolate Points)*

4 In the **Right** viewport, using **Ortho, Move** the text and cleat and text area curves below the sketch. *(Transform menu: Move)*
To model the finished tread and text

1. Turn the **Outsole** layer on. (*Edit menu: Layers > Edit Layers*)
2. **Explode** the polysurface you created previously. (*Edit menu: Explode*)
3. **Hide** all but the bottom surface. (*Edit menu: Visibility > Hide*)

4. **Select** the tread curves and the surface.
5. Use the **Project** command to project the curves onto the surface. (*Curve menu: Curve From Objects > Project*)

If we look at the projected curves now, we can see that for the next step, the cleats should not extend into the text area, so we will trim them back to the outline curves.
To trim the cleat curves out of the text area

1. Select the text area curves and use the **Trim** command to trim away the parts of the cleat rectangles that fall on the same side of the curves as the text. *(Edit menu: Trim)*

   Hide or turn off layers so that only the curves and the rectangles are visible to make this task easier.
2 **Split** the surface with all of the curves to create starting surfaces for the raised cleats and text. *(Edit menu: Split)*

3 **Select** all the text and cleats surfaces to thicken.

4 Use the **OffsetSrf** command with the **Solid** option and an offset distance of **5 mm**. *(Surface menu: Offset Surface)*
   
   Offset the surfaces toward the bottom of the shoe.
5 To show the shoe parts, the color can be changed on some objects.
Create an Insole

In this chapter we are going create an insole based on the men's last model including the heel pad joined to an arch support as anatomical elements.

Information from the last is used to adapt the insole to make insertion, extraction, and adjustment inside the shoe easier.

Correct design and positioning of functioning anatomical elements requires additional information such as podometric or, in the case of customized insoles, pedigraph data.

This example is an exercise in using Rhino to create the shapes. The final insole does not claim to be anatomically valid.

Setting up the model

The insole will be based on the men's shoe last.

To set up the model

1. Open the model Insole Last.3dm.
2. Save it as a new file.
3. Create a layer for the insole bottom surface, and set it as the current layer. (Edit menu: Layers > Edit Layers)
4. Create a layer for the Side surface. (Edit menu: Layers > Edit Layers)
5 Use the **ExtractSrf** command with the **Copy** option to create a copy of the sole surface. *(Solid menu: Extract Surface)*

6 Change the surface to the **Bottom surface** layer. *(Edit menu: Layers > Change Object Layer)*

7 Use the **ExtractSrf** command with the **Copy** option to create a copy of the side surface. *(Solid menu: Extract Surface)*

8 Change the surface to the **Side surface** layer, and turn this layer off. *(Edit menu: Layers > Change Object Layer)*

---

**Scaling the sole**

For the insole to enter the shoe correctly, there must be 0.5 mm space around its perimeter. To scale the sole you will create a bounding box around the sole surface. The bounding box defines the sole's maximum length and width.

**To create a bounding box**

1. Create a **Dimensions** layer, and set it as the current layer. *(Edit menu: Layers > Edit Layers)*

2. Select the sole surface.
3 Use the **BoundingBox** command to create a box around the sole. *(Analyze menu: Bounding Box)*

The sole's maximum length and width dimensions can be obtained by measuring the bounding box.

The scale factors for resizing the sole can be calculated with these formulas:

\[
\%\text{length} = \frac{\text{length}(\text{mm}) - 1}{\text{length}(\text{mm})}
\]

\[
\%\text{width} = \frac{\text{width}(\text{mm}) - 1}{\text{width}(\text{mm})}
\]

for our example, this gives these values:

% width (scale X) = 0.987

% length (scale Y) = 0.996

The bounding box centroid (center of mass) will be used as the point to perform the scale around.

**To resize the insole's base surface**

1 **Select** the bounding box object.

2 Use the **VolumeCentroid** command to place a point object at the center of the bounding box. *(Analyze menu: Mass Properties > Volume Centroid)*

   Place the point on a layer other than the dimension layer.
3 Turn the **Dimensions** layer off. *(Edit menu: Layers > Edit Layers)*

4 Turn the **Side surface** layer on. *(Edit menu: Layers > Edit Layers)*

5 **Select** the side surface and the sole.

6 Start the **ScaleNU** command. *(Transform menu: Scale > Non-Uniform Scale)*

7 At the **Origin point** ... prompt, select the point object at the centroid.

8 At the **X axis scale** ... prompt, type the previously calculated number **0.987**.

9 At the **Y axis scale** ... prompt, type the previously calculated number **0.996**.

10 At the **Z axis scale** ... prompt, press ENTER to accept the default of **1**.

11 Turn the **Side surface** layer off. *(Edit menu: Layers > Edit Layers)*

**Creating the insole thickness**

We are going to design an insole 2 mm thick at the front and 5 mm thick at the back. Greater shock absorbing power is needed at the back for the greater impact at the heel.

**To create the insole’s top surface**

1 Create a new layer for the **Top surface**, and set it as current.

2 Turn off all layers except the **Bottom surface** layer. *(Edit menu: Layers > Edit Layers)*
3 Use the **Line** command with **Ortho** mode and the **End** object snap to create a **2 mm** vertical line at the toe end, and a **5 mm** line at the heel end of the sole. *(Curve menu: Line > Single Line)*

This is easiest to do in the **Right** viewport.

4 **Select** the sole bottom surface and use the **Orient** command with the **Scale=Yes** option to create the top surface. *(Transform menu: Orient > 2 Points)*

5 At the **Reference point 1** ... prompt, set **Copy=Yes**.

   **Scale=Yes** is the default setting, so it should not need to be reset.

6 At the next **Reference point 1** ... prompt, use the **End** object snap to select the bottom end of the 2 mm line at the toe.

7 At the **Reference point 2** ... prompt, use the **End** object snap to select the bottom end of the 5 mm line at the heel.

8 At the **Target point 1** ... prompt, use the **End** object snap to select the top end of the 2 mm line at the toe.
9 At the Target point 2 ... prompt, use the End object snap to select the top end of the 5 mm line at the heel.

Creating the heel pad and arch support
In the next section, we will create the heel pad and arch support areas. We will use an estimated curve for this procedure. To produce a correct functional design for these curves, we would need additional data.

To create the defining curves

1 Create a layer for the anatomy definition curve, and make it current.
2 Turn off all the layers except the Top surface and anatomy layers. (Edit menu: Layers > Edit Layers)
3 In the Top viewport, draw the curve that defines the anatomy of the heel pad.
4 Use the **DupBorder** command to make a copy of the edge of the top surface. (*Curve menu: Curve From Objects > Duplicate Border*)

**To trim the top sole surface**

- Use the **Trim** command to cut away the part of the top surface outside the curve that defines the anatomy. (*Edit menu: Trim*)

We are going to draw planes through the side and sole surfaces and intersect the planes with the surfaces to create the curves that define the insole anatomical element.

**To create the curves that define the insole sides**

1. Turn the **Side surface** layer on. (*Edit menu: Layers > Edit Layers*)

2. Create a **Section planes** layer, and set it as the current layer.
3 Select the side surface and sole.

4 In the Right viewport, use the CutPlane command to draw three rectangles through the shoe from side to side as shown.
   (Surface menu: Plane > Cutting Plane)

5 In the Top viewport, use the CutPlane command to draw a rectangle through the shoe from front to back as shown. (Surface menu: Plane > Cutting Plane)

6 Use the Intersect command to create intersection curves and points from each of the planes with the side surface, the top surface, and sole edge curve. (Curve menu: Curve From Objects > Intersection)
To draw the definition curves for the heel pad and the arch support

1. **Select** the section plane closest to the toe.

2. Use the **CPlane** command with the **Object** option to set the construction plane to match the section plane. *(View menu: Set CPlane > To Object)*
3 In the **Right** viewport, select all the objects in this plane and **Hide** the other objects using commands **Invert** and **Hide**. *(Edit menu: Select Objects > Invert and Edit menu: Visibility > Hide)*

4 Start the **Circle** command. *(Curve menu: Circle > Center, Radius)*
5 Use the **Point** object snap to start the circle at the point object.

6 At the **Radius** ... prompt, type **7**.

7 Use the **InterpCrv** command to draw a curve defining the surface of the arch support area. *(Curve menu: Free-Form > Interpolate Points)*

   Make its starting point the intersection between the circle and the side surface intersection curve.

   Make its final point on the top surface curve.

8 Use the **Match** command with **Continuity** set to **Tangency** and **Preserve other end** set to make the curve tangent to the insole top surface curve. *(Curve menu: Curve Edit Tools > Match)*
9 **Repeat** this procedure with the next section plane.

Draw circles with a radius of **10 mm**.

Draw curves on both sides of the sole curve from the intersection of the circle and the side surface intersection curve.

Use the **Match** command to make them tangent to the sole curve.

10 **Repeat** the process again with the other section cutting plane and with the longitudinal plane curves.

---

**To draw the curves that define the top and bottom edges**

1 Turn the **Top surface** layer on. *(Edit menu: Layers > Edit Layers)*

2 Use the **DupEdge** command to copy the edge of the trimmed area. *(Curve menu: Curve From Objects > Duplicate Edge)*

3 Turn the **Side surface** layer on. *(Edit menu: Layers > Edit Layers)*
4 Use the `InterpCrvOnSrf` command to draw the insole’s upper edge on the side surface. 
*(Curve menu: Free-Form > Interpolate on Surface)*

Use the `End` object snap to start the curve at the end of the duplicated trimmed edge.

Place points at the upper ends of the matched curves you drew in the last step.

End the curve at the opposite end of the trimmed edge.

5 Use the `Rebuild` command to rebuild the curve with 20 control points. *(Edit menu: Rebuild)*
To create the insole edge surface

1. Use the **NetworkSrf** command to create the insole edge surface. *(Surface menu: Curve Network)*
   - Select the curve coinciding with the side surface and the top surface edge in one direction and the cross-section curves that you drew previously in the other direction.
   - Set the **Continuity** option with the insole top surface (C) to **Tangency**.

2. **Join** the new surface to the top sole surface.

Closing the insole

The next step is to create a surface between the insole top surface and the bottom surface to close the insole into a solid.

To create construction curves

1. Turn the **Section planes** and **Side surface** layers on. *(Edit menu: Layers > Edit Layers)*

2. Create a new layer for the **Close surface**, and set it as current.
3 With the **Intersect** command, create intersection curves with the section planes and the side surface. (*Curve menu: Curve From Objects > Intersection*)

4 Turn the **Side surface** and **Section Planes** layers off and turn the **Top surface** and **Bottom Surface** layer on. (*Edit menu: Layers > Edit Layers*)

5 **Trim** the curves corresponding to the side surface back to the point where they intersect with the top surface of the insole. (*Edit menu: Trim*)

   Note: You may have to trim the back heel curve with the curve that defines the top edge of the insole using apparent intersections in the Front viewport.
6 To guide the closed surface in the insole forefoot area which is not covered by the anatomical element, use the **Line** command to draw three lines between the top and bottom surfaces. *(Curve menu: Line > Single Line)*

Draw a line at each end of the heel pad surface and another at the toe end.

---

**To create the closing surface**

1 Use the **DupBorder** command to copy the edges of the bottom surface and the top polysurface. *(Curve menu: Curve From Objects > Duplicate Border)*
Edit the control points at the end of each of the vertical curves to make sure they lie exactly on the top and bottom edge curves.

Zoom in close and use object snaps to make sure the placement is accurate.

This step will help ensure that the closing surface will join properly with the insole top and bottom surfaces.

2. **Select** all of the cross-section curves and use the Rebuild command to make them compatible with **5 control points** and **degree 3**. *(Edit menu: Rebuild)*

3. Use the **Sweep2** command to create the closing surface. *(Surface menu: Sweep 2 Rails)*

   Select the two border curves as the rails.

4. In the **Sweep2** dialog box, select the **Closed sweep** check box.
To finish the insole

1. Turn the **Top surface** and **Bottom surface** layers on. *(Edit menu: Layers > Edit Layers)*

2. Create an **Insole** layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*

3. **Copy** the top surface, bottom surface and closing surface with the **InPlace** option, and change the new surface to the **Insole** layer. *(Transform menu: Copy and Edit menu: Layers > Change Object Layer)*
   - Or -
   Use the **Bonus Tools CopyToLayer** command to copy the parts to the **Insole** layer. *(Bonus menu: Edit > Copy to Objects to Layer)*

4. **Join** the parts. *(Edit menu: Join)*
5 Use the **ShowEdges** command to check for naked edges. *(Analyze menu: Edge Tools > Show Edges)*

There should be no naked edges. If there are, this usually means that the input curves to the surface creation commands did not meet.
5 Modeling the Finish Details

This chapter describes the steps for modeling a complete shoe. This process consists of “dressing” the last with leather uppers or other materials. We are going to use the same 3-D last models and style sketches as in the previous chapters to dress the lasts. The dressed upper will then be combined with the previously modeled soles.

This chapter covers the four examples, a sandal, boot, high-heeled mule, and teen fashion shoe that we have seen started in the previous chapters.

Sandal

Boot

High-heeled mule

Teen fashion shoe
Finishing the Sandal

The sandal has a two-color cut-out upper.
The model file contains real-scale style sketches, the 3-D model of the last, the insole, and the sole.

To set up the model

1. Open the Sandal Finished Details.3dm model.
   This model has everything done on layers that are off.
2. Save it as a new file.
3. Create an Upper layer, and make it the current layer. (Edit menu: Layers > Edit Layers)
4. Copy the last upper surface to the Upper layer. (Bonus menu: Edit > Copy to Objects to Layer)
5. Turn the Last layer off.

Trimming the last to sandal shapes

In this section you will use curves created from the sketch to trim the last into the sandal upper parts.

To trim the last into the sandal shape

1. In the Right viewport, use the InterpCrv command to draw curves defining the sandal's leather upper. (Curve menu: Free-Form > Interpolate Points)
   Trace the background sketch.
2 Use the **ExtrudeCrv** command with the **Straight** option to extrude the curves through the upper shape. *(Surface menu: Extrude Curve > Straight)*

3 Use the **Trim** command to remove the parts of the last with the trimming surfaces. *(Edit menu: Trim)*
   - Select the extended surfaces around the leather edges as the cutting objects.
   - Select the parts overhanging the edge of the upper as the objects to be trimmed.

4 Use the **Split** command to separate the surfaces to simulate material changes. *(Edit menu: Split)*
   - Select the upper surface as the object to split.
   - Select the extruded surfaces around the leather changes as cutting objects.

5 **Select** the upper parts corresponding to the forefoot and the ankle area.
6 Use the **Properties** command to change the color of the parts. *(Edit menu: Object Properties)*

### Simulating the leather thickness

In this section you will offset the surfaces to simulate the thickness of the leather.

**To simulate different leather thicknesses**

1. **Select** the surfaces corresponding to the **gold** colored leather uppers.

2. Use the **OffsetSrf** command with the **Solid** option to offset the surfaces outwards **1 mm**. *(Surface menu: Offset Surface)*
3 Select the surfaces corresponding to the orange colored leather uppers.

4 Use the OffsetSrf command with the Solid option to offset the surfaces outwards 2 mm. (Surface menu: Offset Surface)

This completes the sandal example.
Finishing the Boot

The boot has elastic sides, a lining, and contrasting color stitching.

The model file contains real-scale style sketches, the 3-D model of the last, and the sole.

To set up the model

1. Open the Boot Finished Details.3dm model.
2. Save it as a new file.
   - This model has everything done on layers that are off.
3. Create an Upper layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*
4. Copy the last upper surface to the Upper layer. *(Bonus menu: Edit > Copy to Objects to Layer)*
5. Turn the Last layer off.

Trimming the last to boot shapes

In this section you will use curves created from the sketch to trim the last into the boot upper parts.

To trim the last into the boot upper parts

1. In the Right viewport, use the InterpCrv command to draw the two curves defining the top line of the boot’s upper and the heel stiffener. *(Curve menu: Free-Form > Interpolate Points)*
   - Trace the background sketch.
2 **Select** the curves, and use the **Project** command to project the curves onto the upper surface.

3 With the projected curves, use the **Trim** command to remove the parts of the last that overhang the curves. *(Edit menu: Trim)*

4 With the same projected curves, use the **Split** command to separate the surfaces to simulate the elastic sides of the boot. *(Edit menu: Split)*
5 With the curves at the heel of the boot, use the **Split** command to separate the rear stiffener. *(Edit menu: Split)*

This area will be thicker than the rest of the boot.

**Simulating the leather thickness**

In this section you will offset the surfaces to simulate the thickness of the leather and elastic side materials.

**To thicken the leather parts**

1 **Select** the front boot area surface.

2 Use the **OffsetSrf** command with the **Solid** option to offset the surfaces **outwards** 2 mm. *(Surface menu: Offset Surface)*

3 **Select** the elastic sides.
4 Use the OffsetSrf command with the Solid option to offset the surface outwards 1 mm. (Surface menu: Offset Surface)

5 Select the heel stiffener.

6 Use the OffsetSrf command with the Solid option to offset the surface outwards 2.5 mm. (Surface menu: Offset Surface)

Modeling the boot lining
In this section you will model a simple lining.

To create the lining

1 Create a Lining layer, and make it the current layer. (Edit menu: Layers > Edit Layers)

2 Copy the last upper surface to the Lining layer. (Bonus menu: Edit > Copy to Objects to Layer)

3 Turn the Boot Last layer off.
4  With the projected curves, use the **Trim** command to remove the parts of the last that overhang the curves. *(Edit menu: Trim)*

   Include the elastic cut out areas in the trim.

5  **Select** the lining surface.

6  Use the **OffsetSrf** command with the **Solid** option to offset the surface **inwards 2 mm**. *(Surface menu: Offset Surface)*

Examine the surface carefully.

It is difficult to model the very long edge surface in the sharply rounded areas.

You may find that the surfaces sag inwards.

If this happens, you can improve the model in this area by using a different modeling technique for this surface.
To remodel the edge surface

1. **Explode** the lining polysurface. *(Edit menu: Explode)*
   - **Delete** the incorrect surface.

2. Use the **Line** command to draw several lines from the outer surface edge to the inner surface edge. *(Curve menu: Line > Single Line)*
   - Draw extra lines across the gap at the sharply curved areas.

3. Use the **Sweep2** command to create a surface between the two surface edges. *(Surface menu: Sweep 2 Rails)*

4. **Join** all of the surfaces. *(Edit menu: Join)*
Modeling the decorative stitching
In this section you will model the decorative stitching along the seam line of the upper.

To create the seam line

1. Turn the Lining layer off.
2. In the Right viewport, use the InterpCrv command, to draw the curve that marks the seam position in the vamp. *(Curve menu: Free-Form > Interpolate Points)*
3. Select the curve and use the Project command to project it to the upper polysurface.
4. Delete any extra curves created by the Project command.

To simulate the inside stitched seam

1. Create a Seam stitching layer, and make it the current layer. *(Edit menu: Layers > Edit Layers)*
2 Use the **Cylinder** command with the **AroundCurve** option and the **End** object snap to create a cylinder with a **0.5 mm** radius around the seam curve. (*Solid menu: Cylinder*)

Make the cylinder about **1.8 mm** long.

3 Use the **ArrayCrv** command to copy the cylinder along the seam curve. (*Transform menu: Array > Along Curve*)

Set the distance between items to about **3.3 mm**.

---

**To simulate the outside stitched seam**

The outside seam curve does not have as nice a shape as the inside seam curve did. To improve the shape of the projected curve, you should edit this curve.
1 **Rebuild** the curve with 10 control points.
   *(Edit menu: Rebuild)*

2 Turn the control points on and edit the curve in the **Top** and **Right** viewports until you get an appropriate shape.

3 **Pull** the surface back to the vamp surface after editing. *(Curve menu: Curve From Objects > Pullback)*

4 As in the previous section, use the **Cylinder** command with the **AroundCurve** option and the **End** object snap to create a cylinder with a 0.5 mm radius around the seam curve. *(Solid menu: Cylinder)*
   
   Make the cylinder about 1.8 mm long.
5 Use the **ArrayCrv** command to copy the cylinder along the seam curve. (*Transform menu: Array > Along Curve*)

Set the distance between items to about **3.3 mm**.

This completes the boot example.

---

**Finishing the High-Heeled Shoe**

The high-heeled shoe is an open-back mule with piping trim on the vamp. The model file contains real-scale style sketches, the 3-D model of the last, and the sole.
To set up the model

1. Open the High heel shoe.3dm model. The file contains the sole and heel that were modeled previously and the last that will be used to create the vamp and trim.

2. Create a Vamp layer, and make it the current layer. (*Edit menu: Layers > Edit Layers*)

3. Copy the last upper surface to the Vamp layer. (*Bonus menu: Edit > Copy to Objects to Layer*)

4. Turn the Last layer off.

Trimming last to vamp shape

In this section you will use curves created from the sketch to trim the last into the shoe’s upper parts.

To create the vamp surface

1. In the Right viewport, referring to the style sketch, use the Line command to trace a straight line that defines the last vamp edge. (*Curve menu: Line > Single Line*)
2 Use the **Trim** command to cut away the surface. *(Edit menu: Trim)*

---

**Simulating the leather thickness and decorative piping**

In this section you will offset the surfaces to simulate the thickness of the leather and create decorative piping at the top of the vamp.

**To thicken the vamp surface**

1 **Select** the front vamp surface.

2 Use the **OffsetSrf** command with the **Solid** option to offset the surfaces **outwards** **1 mm**. *(Surface menu: Offset Surface)*
To create the piping

1. Use the **DupEdge** command to create a curve from the upper edge of the vamp polysurface. *(Curve menu: Curve From Objects > Duplicate Edge)*

2. Use the **Extend** command with the **Smooth** option to extend each end of the curve so that it passes inside of the sole polysurface. *(Curve menu: Extend Curve > Extend Curve)*

3. Use the **Pipe** command with the **Diameter** option to create a **3.5 mm** diameter surface around the duplicated edge curve. *(Solid menu: Pipe)*
4 Use the **Trim** command to cut away the parts of the piping surface inside the sole polysurface. *(Edit menu: Trim)*

This completes the high-heeled shoe.

**Finishing the Teen Fashion Shoe**

The teen shoe has contrasting details: a lining, eyelets, laces, and contrasting color stitching around the sole.

The model file contains real scale style sketches, the 3-D model of the last, and the sole.
To set up the model

1. Open the Teen shoe.3dm model.
   The file contains the sole and heel that were modeled previously and the last that will be used to create the upper and decoration.

2. Create an Upper layer, and make it the current layer. (Edit menu: Layers > Edit Layers)

3. Copy the last upper surface to the Upper layer. (Bonus menu: Edit > Copy to Objects to Layer)

Trimming last to shoe shapes
In this section you will use curves created from the sketch to trim the last into the shoe upper parts.

To define the decoration

1. Create a Definition curves layer, and make it the current layer. (Edit menu: Layers > Edit Layers)

2. Turn the other layers off.

3. In the Right viewport, use the InterpCrv command to draw the curves defining the leather uppers following the style sketch. (Curve menu: Free-Form > Interpolate Points)

4. Turn the Upper layer on.
5 In the Right viewport, use the Project command to project the curves to the surface of the upper. *(Curve menu: Curve From Objects > Project)*

To trim and split the upper

1 Use the Trim command to trim the topline edge with the projected curve. *(Edit menu: Trim)*

2 Use the Split command to divide the upper surface with the curves that represent the side decoration, the toe, tongue, and rear stiffening. *(Edit menu: Split)*
Simulating the leather thickness
In this section you will offset the surfaces to simulate the thickness of the leather and create decorative material.

To add thickness to the leather parts

1. **Select** the surfaces corresponding to the side decoration, the toe, tongue, and rear stiffening.

2. Use the **OffsetSrf** command with the **Solid** option to offset the surfaces **outwards 2 mm**. (*Surface menu: Offset Surface*)

3. Create an **Upper decoration** layer, and make it the current layer. (*Edit menu: Layers > Edit Layers*)

4. Change the layer of the side decoration polysurfaces to the **Upper decoration** layer. (*Edit menu: Layers > Change Object Layer*)
Creating the padded cuff

In this section you will thicken the cuff area to create a padded effect.

To create the cuff padding definition curves

1. Select the upper surface around the topline of the shoe.

2. Use the DupBorder command to copy the surface border. *(Curve menu: Curve From Objects > Duplicate Border)*

3. Explode the border curve and then rejoin the curves so there are four curves: the two that define the top and bottom of the surface (1) and (2) and the two that define the front ends of the surface (3) and (4). *(Edit menu: Explode)*

4. Use the CPlane command with the Curve option to set the construction plane perpendicular to the top surface border curve. *(View menu: Set CPlane > Perpendicular to Curve)*
5 Use the **Rectangle** command to draw a plane that passes through the border curves. *(Curve menu: Rectangle > Corner to Corner)*

6 Use the **Intersect** command to create points at the intersection of the border curves and the plane. *(Curve menu: Curve From Objects > Intersection)*

7 Use the **InterpCrv** command to draw the section curve for the padding. *(Curve menu: Free-Form > Interpolate Points)*

Start and end the curve at the intersection points. This ensures that the curve endpoints lie exactly on the border curve.
8 **Repeat** steps these steps to move the construction plane along the border curve.

9 **Draw** more cross-section curves to define the padding.

   The shape of curve at the heel is traced from the design sketch background image.

**To create the cuff padding**

- Use the **Sweep2** command to create the cuff padding surface. (*Surface menu: Sweep 2 Rails*)

   Select curves 1 and 2 as the rail curves.
   Select the cross-section curves and the surface end curves as the cross-sections.
Modeling the lining

In this section you will model a curved lining for the rear section of the shoe.

To create the lining definition curves

1. **Copy** the topline curve to a new Lining layer. *(Bonus menu: Edit > Copy to Objects to Layer)*

2. Turn the **Last** layer on.

3. Use the **DupBorder** command to copy the border of the last sole surface. *(Curve menu: Curve From Objects > Duplicate Border)*
4 Use the **Offset** command to offset the sole curve **5 mm** to the inside. *(Curve menu: Offset Curve)*

5 In the **Right** viewport, copy the inside curve **5 mm** up. *(Transform menu: Copy)*
   
   You can **Hide** or delete the first two curves.

6 In the **Right** viewport, use the **Line** command with the **FourPoint** option to draw a construction line. *(Curve menu: Line > From 4 Points)*
   
   Use the **Project** option in the **Osnap** toolbar to project the line to the construction plane.
   
   Use the **End** object snap to start the base line at the endpoint of the copied topline curve.
   
   Draw the line above and below the shoe sketch.
7 In the **Right** viewport and the **Back** viewport, use the **Project** command to project the line to the last surface. *(Curve menu: Curve From Objects > Project)*

The curve projected to the toe portion of the last will not be used.

8 Turn the **Last** layer off.

9 In the **Right** viewport, use the **Trim** command to trim away the front section of the copied sole curve with the vertical construction line. *(Edit menu: Trim)*

---

**To create the lining definition curves**

1 In the **Back** viewport, use the **CPlane** command with the origin option to move the construction plane origin to the end of the sole curve. *(View menu: Set CPlane > Origin)*
2 In the Back viewport, with the projected curve as a visual guide, use the InterpCrv command to draw a section curve for the lining from the endpoint of the topline curve to the endpoint of the sole curve. *(Curve menu: Free-Form > Interpolate Points)*

Turn Osnap Project mode off and Planar mode on.

3 Draw a similar curve on the opposite side of the shoe.

4 In the Right viewport, draw one more curve at the heel.
To create the lining surface

- Use the **Sweep2** command to create the lining surface. *(Surface menu: Sweep 2 Rails)*
  Select curves 1 and 2 as the rail curves.

Modeling the welt and stitching

In this section you will model the welt and the decorative stitching that sews the upper to the sole.

To create the welt

1. Use the **DupBorder** command to copy the edge of the last sole. *(Curve menu: Curve From Objects > Duplicate Border)*
2 Use the **Line** command to draw a **5.5 mm** line at the front and rear of the sole curve. *(Curve menu: Line > Single Line)*

   Use the **Quad** object snap to start the line.

3 Use the **Sweep1** command with the **Closed** option to draw a surface using the sole curve as the rail and the two short curves as the cross sections. *(Surface menu: Sweep 1 Rail)*
4 Use the **OffsetSrf** command with the **Solid** option to offset the surface **downward** 2 mm. (*Surface menu: Offset Surface*)

---

**To create the welt stitching**

The next step is to model the welt stitching.

1 Use the **ExtractIsocurve** command to create a curve from the top surface of the welt. (*Curve menu: Curve From Objects > Extract Isocurve*)

   Use the **End** object snap to snap to an edge of the offset leather.

2 Use the **Cylinder** command with the **AroundCurve** option to create a cylinder with a 1 mm radius and a length of 4 mm around the extracted curve. (*Solid menu: Cylinder*)
3 Use the **ArrayCrv** command to copy the cylinder along the seam curve. *(Transform menu: Array > Along Curve)*

Set the distance between items to about **5.3 mm.**

### Creating the eyelet tabs
In this section you will create the eyelet tabs and the holes for the shoelaces.

**To create the eyelet tabs**

1 In the **Top** and **Right** viewports use the **InterpCrv** command to draw the **2-D** curves that define these surfaces’ top edges. *(Curve menu: Free-Form > Interpolate Points)*
2 Use the **Crv2View** command to create the 3-D curves that define the top of the eyelet tabs. *(Curve menu: Curve From 2 Views)*

3 Use the **CPlane** command with the **Curve** option to set construction planes perpendicular to the curve. *(View menu: Set CPlane > Perpendicular to Curve)*

4 Use the **InterpCrv** command to draw cross-section curves starting from the top curve and ending at the inner edge of the tongue polysurface. *(Curve menu: Free-Form > Interpolate Points)*

5 Use the **NetworkSrf** command to create a surface using the cross-section curves, the top curve, and the tongue inner edge. *(Surface menu: Curve Network)*
6 Repeat this process on the other side.

7 Use the **OffsetSrf** command with the **Solid** option to offset the eyelet tab surfaces **outward 2 mm**. *(Surface menu: Offset Surface)*

Creating the eyelets

In this section you will model the eyelets for the shoelaces.

**To create the eyelets**

1 In the **Right** viewport, using the design sketch as a reference, use the **Points** command to create a point object at the center of each eyelet hole. *(Curve menu: Point Object > Multiple Points)*
2 Use the **Project** command to project the point objects to the eyelet tabs. *(Curve menu: Curve From Objects > Project)*

3 **Delete** the points projected to the tab’s inner surface.

4 At each point, use the **Line** command with the **Normal** option to create a line segment normal to the eyelet tab surface. *(Curve menu: Line > Normal to Surface)*

   The length of the line is not important.

5 **Hide** the point objects. *(Edit menu: Visibility > Hide)*
6 Use the **Circle** command with the **AroundCurve** option to draw a **3 mm** circle and a **6 mm** circle at the surface endpoint of each line. *(Curve menu: Circle > Center, Radius)*

7 **Select** a set of two circles that define one eyelet.

8 Use **ExtrudeCrv** command with the **BothSides** option on and the **Cap** option on to generate a solid. *(Surface menu: Extrude Curve > Straight)*

   At the **Extrusion distance** prompt, type **1**.

9 **Repeat** this process for all of the eyelets.
Creating the laces
The next step is to create the shoelaces. The directions for the laces are divided into two parts: the upper laces and the lower laces.

To create the upper laces

1. In the Back viewport, use the InterpCrv command to draw a flat curve approximating the shape of the lace. *(Curve menu: Free-Form > Interpolate Points)*
   - Use the Quad object snap to start and end the curve at the heel-side quadrant of the inner eyelet circles.

2. In the Right viewport, use the Rotate command to set an angle for the curve. *(Transform menu: Rotate)*

3. Use the Line command to draw a line about 4.7 mm long at each end of the curve. *(Curve menu: Line > Single Line)*
4 Use the **Sweep1** command to create the lace upper surface. *(Surface menu: Sweep 1 Rail)*

5 Use the **OffsetSrf** command with the **Solid** option to offset the lace surface **inward 1 mm**. *(Surface menu: Offset Surface)*

6 **Repeat** this process to create the remaining laces.

**To create the lower laces**

The lower laces are modeled based on the tongue upper surface.

1 **Hide** the laces you have created previously. *(Edit menu: Hide)*
2 Use the **ExtractSrf** command to copy the upper surface of the tongue. (*Solid menu: Extract Surface*)

3 Use the **ChangeLayer** command to change the layer of the tongue surface to a **Laces** layer. (*Edit menu: Layers > Change Object Layer*)

4 In the **Top** viewport, use the **Line** command to draw straight lines that define the lace edges. (*Curve menu: Line > Single Line*)

5 In the **Top** viewport, use the **Trim** command to cut away the areas of the tongue that are not the laces. (*Edit menu: Trim*)
6 Use the **OffsetSrf** command with the **Solid** option to offset the lace surface **outward** 1 mm. *(Surface menu: Offset Surface)*

This completes the teen shoe.
6 Create Images

The chapter gives a brief overview of some of the methods for creating images of your models. Rather than giving detailed step-by-step explanations of the commands or tools that can be used when rendering this chapter give simple descriptions of methods appropriate for presenting our projects. Various degrees of complexity are shown, from simple viewport captures to complex photorealistic rendering with Flamingo.

Models and material libraries are included on the CD so you can study the rendering setup and materials.

For information about photorealistic images in greater depth, refer to the advanced training CD for Flamingo: Studio-Quality Rendering, by Gijs de Zwart.

Types of Images

There is a range of image types you can create with Rhino ranging from simple viewport captures to complex photorealistic renderings with lighting effects, complex materials, and backgrounds.

Rhino offers several built-in rendering methods: screen captures of shaded viewports, Treefrog render, and Rhino render.

Viewport captures

Viewport captures are an extremely quick way to show a sketch image for presentations. Images from the viewports can be captured directly with the Rhino commands ViewCaptureToClipboard and ViewCaptureToFile. Other commands to enhance your images include ShadedViewport, GhostedViewport, AdvancedDisplay, and GradientView.

Gradient view and grid.

White background, no grid.
Gradient view.

Gradient view and grid with darker lines for major grid lines.

**Simple rendering with Treefrog**

Rhino’s built-in quick rendering tool, Treefrog, gives quick shaded views of a higher quality than a viewport capture.

Treefrog render with background color.

Treefrog render with white background.
Raytrace render with Rhino render
Rhino’s built-in raytrace renderer gives textures, bumps, highlights, and transparency.

Sketch rendering with Penguin
Another option for sketch style images is to use the Penguin renderer. Penguin creates cartoon and sketch style renderings. These quick rendering methods are especially useful during early design phases when too elaborate an image gives the impression of finished products. A sketch style rendering gives a comfortable feeling while leaving room for design changes. You can examine color options with styles similar to using felt pen, watercolor, or colored pencil rendering.
Photorealistic rendering with Flamingo

Once your designs are ready for more elaborate rendering, you can choose a photorealistic rendering program such as Flamingo. These programs are more complex and require more sophisticated lighting, materials, and backgrounds for good results.
Set Up the Scene
Achieving these results requires four basic steps:

- Set up the view
- Set up the lighting
- Add materials to the model
- Add environment to the scene

Make a pair and place the shoes
The first step is to compose the model elements to prepare the image and get the best possible information about your design.

Because we are dealing with shoes, you can start your scene by creating the left shoe in each case. Use the Mirror command to create a copy of the shoe. Use the Move and Rotate commands to create an interesting composition.
Set up the view

The focal distance can be adjusted interactively using the Camera command. The Camera command shows the current viewport’s camera in the other views. Once the camera is displayed, you can change the camera angle and focal distance by moving control points.

Look for a correct perspective that shows the shoe like a photograph using an focal distance (50 to 100 mm) similar to that of a conventional photographic camera.

If you want to use a specific focal distance, use the ViewportProperties command. In the ViewportProperties dialog box, you can enter an exact focal length, for example 100 mm. You can then move the camera in the orthogonal views until you get an appropriate frame in the Perspective view.

Once the image has been framed, use the NamedView command to save the view. Save additional views that you might want to use later.

Lighting

The next step is to light your scene. The principles of photographic lighting also apply to computer rendering. Any good book on photographic lighting for product design will help you learn to expertly light your models.

For both examples, a standard three-light photographic setup with a key light, a fill light, and a back light was used. For the high-heeled shoe, spotlights are used. The teen shoe is lit by point lights.

The completed models on your CD have lighting already set up. You can examine these examples to see how the lighting was done for these models.

It is a good idea to use white materials on your models to set up the lighting. Material color values can distort the lighting effects.
High-heeled shoe

The key light determines the direction the light hits the shoes. The key light’s shadow will be the most noticeable among the collection of lights in the scene. The lighting settings are from Flamingo, but the same ideas work for other renderers.

Locate the key light’s focus to the side of the shoes so that its shadow is neither too vertical nor too long. Confused or exaggerated shadows reduce the image quality.

Once the spotlight has been positioned, rotate it to get the shadow direction you want.
When you have found the correct direction, use the **Properties** command to adjust the intensity of the light and the hardness of the shadows.

In this case, the **Light intensity** is set to **30** and the **Shadow intensity** is set to **75**.

This gives better illumination than in the previous image, and the shadow hardness is reduced to give the image more clarity.

Turn the key light off and create the fill and back lights to light the dark parts that, in a real situation, would be illuminated naturally due to light dispersion.
Set the light intensity to a very low value.

To check the lighting, turn on the key light and render again.
Dark areas are reduced without losing contrast.

**Teen shoe**

The illumination and the properties of the shadows in this image are created by the default lighting.
To illuminate the scene, we are going to use three point lights: a key light, a fill light, and a back light.

Place the main light very close to the camera, the fill light at a high point above the shoes, and the back light very far back at a similar height as the shoes.

When you render, you can see the illumination and the shadow properties.

The image is a little over-illuminated and the shadows are confused, so adjustments are required.
Modify the lights one by one to adjust the illumination.

In this case the first light to be adjusted is the fill light.

Hide the key light and the back light, and use the Properties command to set the light’s properties. The Light intensity is set to 12 and the Shadow intensity is set to 50.

The color of the light is also changed to blue. Using colored lights adds depth and interest to the shadow areas and highlights.

Adjust the key light in the same way.

Hide the other lights (or turn them off).

In this case, the color of the light is a light yellow, the Light intensity is 15, and the Shadow intensity is 20.

Finally, adjust the back light.

Use a white light to bring out the upper edges of the shoes. The Light intensity is 20, and the Shadow intensity is 15.
Render the scene with the three lights.

**Materials**

Once the scene and the illumination have been created, we can apply material to the shoes. Think about color, texture, shine, and reflections.

To learn the details of the material properties, examine the finished models provided on the CD.

**High-heeled shoe**

First we will examine the materials for the high-heeled shoe.

For these examples, the Flamingo rendering plug-in for Rhino has been used. Other rendering applications provide similar abilities to apply materials (sometimes called “shaders”) to the parts.

Start by selecting a material that is close to your idea, in this case an orange plastic.

A sandpaper texture has been used with a scale that makes a small variation in the color.

The shine intensity is rather low so the material is quite matte.
A red plastic material with some roughness has been applied to the heel.

On the vamp and piping, we can do more experimenting to change the styles. We are going to create three different materials to evaluate possible shoe design finishes.

The first material is a white leather with black spots.
To create this material, add an image map of spots to a neutral white material.

The image Dalmatian.jpg is used to create the spots.
Now apply a black patent material to the upper. Start with a black material and modify its shine and reflective finish.

By simply changing the base color to red, you can achieve another effect.

To create brown leather, add a bump map to a brown material.
The image map for the bump is `leather.jpg`.

**Teen shoe**

The leather upper parts are dark blue with shine and sandpaper texture.

If all of the parts that are the same material are on a single layer, it makes assigning materials easier. In this model, all of the main leather parts have been placed on the upper layer and the material is assigned to the layer rather than directly to the objects.

The Logo layer has the same characteristics as the previous material, but the main color has been changed to a light blue.
The sole is manufactured in different colored rubber materials.
Define materials in white, red, black, and beige colors, eliminating the shine to simulate a matte finish.
In this case, the materials for the white, red, and black parts are assigned as object properties, overriding the layer assignment for the outsole.

The lining of the shoe and the stitching that joins the sole to the upper have similar materials.
For the eyelet holes, you can use a metal such as anodized aluminum.

Finally, assign material to the shoelaces. Apply a small texture simulating the pattern of the shoelace.
The Shoelace_bump.jpg image is used.
To add a bit of extra realism, you can model the ends of the shoelaces.

Rendering Environment

The environment includes any backgrounds, images, clouds, plants, or other accessories added to the rendering to enhance the image of the model.

Use colors, images, and other effects to create backgrounds for your images.
**Ground Plane**

Objects look natural when they cast shadows on a surface that acts as a floor. You can place a rectangular plane under the shoes to create a floor on which shadows are projected.

- **Rhino Render with no floor.**
- **Rhino Render with planar surface floor.**

If you are using Flamingo as your renderer, you can use Flamingo’s **Ground Plane** feature to create a floor that renders quickly.

- **Flamingo Render with no floor.**
- **Flamingo Render with ground plane.**
Using different materials for the ground plane lets you change the way the objects are displayed and changes the effects of the shadows.

- **White floor.**
- **Plain chrome (mirror) floor.**
- **Brick floor.**
- **White brick floor.**
- **Reflective pink floor.**
- **Reflective floor with color bump.**